summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-07 15:10:04 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-07 15:57:39 -0800
commite37692c66c4ab28bf13d9c5d12fcda7e80c95b4f (patch)
treeb90133606f2b6ce14db635f903ecf8612b2c6364 /sys-fs
parentsys-fs/zfs-kmod: revbump, add HOLE patch and dist-kernel version limit (diff)
downloadgentoo-e37692c66c4ab28bf13d9c5d12fcda7e80c95b4f.tar.gz
gentoo-e37692c66c4ab28bf13d9c5d12fcda7e80c95b4f.tar.bz2
gentoo-e37692c66c4ab28bf13d9c5d12fcda7e80c95b4f.zip
sys-fs/zfs-kmod: backport dist-kernel limiter to 2.0.6 and 0.8.6
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild5
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-2.0.6.ebuild13
2 files changed, 17 insertions, 1 deletions
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild
index e5b3df641c98..3d63f3f393bf 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild
@@ -16,6 +16,10 @@ else
KEYWORDS="amd64 arm64 ppc64"
S="${WORKDIR}/zfs-${PV}"
ZFS_KERNEL_COMPAT="5.9"
+
+ # increments minor eg 5.14 -> 5.15, and still supports override.
+ ZFS_KERNEL_DEP="${ZFS_KERNEL_COMPAT_OVERRIDE:-${ZFS_KERNEL_COMPAT}}"
+ ZFS_KERNEL_DEP="${ZFS_KERNEL_DEP%%.*}.$(( ${ZFS_KERNEL_DEP##*.} + 1))"
fi
LICENSE="CDDL debug? ( GPL-2+ )"
@@ -31,6 +35,7 @@ RDEPEND="${DEPEND}
BDEPEND="
dev-lang/perl
virtual/awk
+ dist-kernel? ( <virtual/dist-kernel-${ZFS_KERNEL_DEP}:= )
"
# PDEPEND in this form is needed to trick portage suggest
diff --git a/sys-fs/zfs-kmod/zfs-kmod-2.0.6.ebuild b/sys-fs/zfs-kmod/zfs-kmod-2.0.6.ebuild
index 5c445cce099f..d12b2a434901 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-2.0.6.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-2.0.6.ebuild
@@ -21,6 +21,10 @@ else
S="${WORKDIR}/zfs-${PV%_rc?}"
ZFS_KERNEL_COMPAT="5.14"
+ # increments minor eg 5.14 -> 5.15, and still supports override.
+ ZFS_KERNEL_DEP="${ZFS_KERNEL_COMPAT_OVERRIDE:-${ZFS_KERNEL_COMPAT}}"
+ ZFS_KERNEL_DEP="${ZFS_KERNEL_DEP%%.*}.$(( ${ZFS_KERNEL_DEP##*.} + 1))"
+
if [[ ${PV} != *_rc* ]]; then
KEYWORDS="amd64 arm64 ppc64"
fi
@@ -39,8 +43,15 @@ BDEPEND="
virtual/awk
"
+# we want dist-kernel block in BDEPEND because of portage resolver.
+# since linux-mod.eclass already sets version-unbounded dep, portage
+# will pull new versions. So we set it in BDEPEND which takes priority.
+# and we don't need in in git ebuild.
if [[ ${PV} != "9999" ]] ; then
- BDEPEND+=" verify-sig? ( app-crypt/openpgp-keys-openzfs )"
+ BDEPEND+="
+ verify-sig? ( app-crypt/openpgp-keys-openzfs )
+ dist-kernel? ( <virtual/dist-kernel-${ZFS_KERNEL_DEP}:= )
+ "
fi
# PDEPEND in this form is needed to trick portage suggest