summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-28 08:47:54 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-28 09:07:45 +0200
commite44504efa6e541569f2106d4a83af1ecaf67fad8 (patch)
treed20703fec977683351ba759c145d186eb24761dc /sys-fs
parentdev-ruby/rmagick: stable 3.1.0 for ppc, bug #688194 (diff)
downloadgentoo-e44504efa6e541569f2106d4a83af1ecaf67fad8.tar.gz
gentoo-e44504efa6e541569f2106d4a83af1ecaf67fad8.tar.bz2
gentoo-e44504efa6e541569f2106d4a83af1ecaf67fad8.zip
sys-fs/vhba: Bump to 20190827
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/vhba/Manifest1
-rw-r--r--sys-fs/vhba/vhba-20190827.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-fs/vhba/Manifest b/sys-fs/vhba/Manifest
index 667f7ec876d8..d70612f60b74 100644
--- a/sys-fs/vhba/Manifest
+++ b/sys-fs/vhba/Manifest
@@ -1 +1,2 @@
DIST vhba-module-20190410.tar.bz2 15741 BLAKE2B 6d513877c771b1c4c5805231cf8bb13333d29dd3c6de7d91879ef1898fdc424df026b0835a772f398dcdc7d8900db462164a40e46c9b66b38ed70f5b5f6a0e7e SHA512 e4b30bea8464d8ac24fd2fddca9d41052af2f5b3dc9e054ead47991bff41366be377600075627c40261722c88c20ed2eaf65fa7afb34690ef09a6f4ea6f9351f
+DIST vhba-module-20190827.tar.bz2 15570 BLAKE2B 54a50f14659e388c0d53edce842633a3d85bae66483d27e458a83fcc7c547a804e83d34bba0e9a11a0b7e4e533f78c7014ac8e1235a83a7dc6aa13671cb9a823 SHA512 e84ffbbace9964b5fda844d3dd5201ae969ca017886a709d814670a371631376ebb2b1f05775c14ace43e84ed7fc0340638e485ac2a386db530cc25a9fa6e534
diff --git a/sys-fs/vhba/vhba-20190827.ebuild b/sys-fs/vhba/vhba-20190827.ebuild
new file mode 100644
index 000000000000..a049dfd927d2
--- /dev/null
+++ b/sys-fs/vhba/vhba-20190827.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils linux-mod udev
+
+MY_P=vhba-module-${PV}
+DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+MODULE_NAMES="vhba(block:${S})"
+BUILD_TARGETS=modules
+
+pkg_setup() {
+ CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
+ check_extra_config
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR}"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ # Avoid -Werror problems
+ sed -i -e '/ccflags/s/-Werror/-Wall/' Makefile || die "sed failed"
+
+ eapply_user
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog README
+ linux-mod_src_install
+
+ einfo "Generating udev rules ..."
+ dodir "$(get_udevdir)"/rules.d
+ cat > "${D}$(get_udevdir)"/rules.d/69-vhba.rules <<-EOF || die
+ # do not edit this file, it will be overwritten on update
+ #
+ KERNEL=="vhba_ctl", SUBSYSTEM=="misc", TAG+="uaccess"
+ EOF
+}