summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-01-26 20:24:26 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-01-26 20:32:47 +0100
commite4698c4fb9e801fdce3b29bed143889869b84c3d (patch)
treeae01429451346958d708852d586da6300fe0935c /sys-fs
parentsys-block/ndctl: add 75 (diff)
downloadgentoo-e4698c4fb9e801fdce3b29bed143889869b84c3d.tar.gz
gentoo-e4698c4fb9e801fdce3b29bed143889869b84c3d.tar.bz2
gentoo-e4698c4fb9e801fdce3b29bed143889869b84c3d.zip
sys-fs/fswatch: add 1.17.1
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fswatch/Manifest1
-rw-r--r--sys-fs/fswatch/fswatch-1.17.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/sys-fs/fswatch/Manifest b/sys-fs/fswatch/Manifest
index b9e7a1470faf..29ad9d3d7c9c 100644
--- a/sys-fs/fswatch/Manifest
+++ b/sys-fs/fswatch/Manifest
@@ -1 +1,2 @@
DIST fswatch-1.16.0.tar.gz 844804 BLAKE2B 55527e7d38421f16a9d2c51b5455b73de54220d280233d905a02d192bc374ef91b02c0d68dcd1c1ed6a29351421df0cd0ee9fad50bb98ec9c9018088a6064d4b SHA512 80100b92f5acef503436bbb684f07f5b692099a7eee0970a61c04670de67cd9bfa7942af40b348236dd97fc4d02fcd6a081b96486332efbd06500379c1eff806
+DIST fswatch-1.17.1.tar.gz 853852 BLAKE2B 0d4d6a350325d4c7cc4ed4277e640d3fa4bfade5ec92b1c27abee9b506f34a024abadfbd5f002fdb3afd80a4ae432a071dd94c664123f447167ded6d5dbbaf9d SHA512 8d98b12e538026545052763961fe7d8147809958c25921bc30f43ba0d63c7f63a00c4b8412bbb63e3d1a0807687f8821f20e2667ee716b439cfb254ce346ccad
diff --git a/sys-fs/fswatch/fswatch-1.17.1.ebuild b/sys-fs/fswatch/fswatch-1.17.1.ebuild
new file mode 100644
index 000000000000..1ff71d7d6e2d
--- /dev/null
+++ b/sys-fs/fswatch/fswatch-1.17.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="cross-platform file change monitor with multiple backends"
+HOMEPAGE="https://github.com/emcrisostomo/fswatch"
+SRC_URI="https://github.com/emcrisostomo/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/13"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="nls static-libs"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name "*.la" -delete || die
+}