summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2016-02-20 18:41:36 +0100
committerSebastian Pipping <sping@gentoo.org>2016-02-20 18:41:55 +0100
commite48f7ee3d7c7146611a7c06f12cce85100685a6f (patch)
tree0a4b98048810221223d231051324aa899aa19c95 /sys-fs
parentsys-fs/pytagsfs: Add missing dependency (bug #513422) (diff)
downloadgentoo-e48f7ee3d7c7146611a7c06f12cce85100685a6f.tar.gz
gentoo-e48f7ee3d7c7146611a7c06f12cce85100685a6f.tar.bz2
gentoo-e48f7ee3d7c7146611a7c06f12cce85100685a6f.zip
sys-fs/pytagsfs: distutils-r1 + EAPI 5
Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/pytagsfs/pytagsfs-0.9.2.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/sys-fs/pytagsfs/pytagsfs-0.9.2.ebuild b/sys-fs/pytagsfs/pytagsfs-0.9.2.ebuild
index d1e21251d24d..4bc47c23990e 100644
--- a/sys-fs/pytagsfs/pytagsfs-0.9.2.ebuild
+++ b/sys-fs/pytagsfs/pytagsfs-0.9.2.ebuild
@@ -1,15 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="2"
-PYTHON_DEPEND="2:2.5"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.4 3.* *-jython 2.7-pypy-*"
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-DISTUTILS_SRC_TEST="setup.py"
+EAPI="5"
-inherit distutils
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_IN_SOURCE_BUILD=yes
+
+inherit distutils-r1
MY_PV="${PV/_/}"
MY_P="${PN}-${MY_PV}"
@@ -40,3 +38,7 @@ DEPEND="${RDEPEND}
media-sound/madplay
media-sound/vorbis-tools
media-libs/flac )"
+
+python_test() {
+ ${PYTHON} setup.py test || die
+}