summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-31 00:02:49 +0100
committerMichał Górny <mgorny@gentoo.org>2015-10-31 00:37:35 +0100
commite65466f4ac25201c7e08f06537ea50ef95b7a016 (patch)
tree754fe59634410a001951ba456474695d9075126b /sys-fs
parentdev-lang/ekopath: Remove snapshots predating 6.0.551_p20151010 (diff)
downloadgentoo-e65466f4ac25201c7e08f06537ea50ef95b7a016.tar.gz
gentoo-e65466f4ac25201c7e08f06537ea50ef95b7a016.tar.bz2
gentoo-e65466f4ac25201c7e08f06537ea50ef95b7a016.zip
sys-fs/bedup: version bump to 0.10.0, #564368
Major changes (from release notes): * Require Python 3 (3.3 and newer) -> solves recursion issues * Require a UTF-8 terminal and locale * Increase robustness against bad encodings, bad data on disk, non-checksummed extents, stale file handles, unusual labels Fixes: https://bugs.gentoo.org/show_bug.cgi?id=564368
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bedup/Manifest1
-rw-r--r--sys-fs/bedup/bedup-0.10.0.ebuild27
-rw-r--r--sys-fs/bedup/bedup-9999.ebuild12
3 files changed, 35 insertions, 5 deletions
diff --git a/sys-fs/bedup/Manifest b/sys-fs/bedup/Manifest
index 039529ae1354..31aa2a22265d 100644
--- a/sys-fs/bedup/Manifest
+++ b/sys-fs/bedup/Manifest
@@ -1 +1,2 @@
+DIST bedup-0.10.0.tar.gz 48058 SHA256 088b31821d8b770d6127ffd7a55e6d5cf21d43b36763e984030d16b677f52fe4 SHA512 6389f4f6d81062ebd3707a620f334278f7bb55449e1de6f0d56a3d2e87d7e2f1694fdfaf2f0b318487fd25db0344b704f297aa4410fac838a9f0ed7891cdcd62 WHIRLPOOL 14a6ed728eb1dfcca47b55b448711bd5c74ed83f7151eed49f10e8f1f06385b1660f2a4bbd85d512ed7574cc2ee2d9f581a8cc7fcba4f8b5c64ccc2632824e35
DIST bedup-0.9.0_p20140413.tar.gz 48620 SHA256 f9c380074e3f13e42447c04a0fd5c1abca444487cf6ccb6400f09dcca14f90a6 SHA512 9a730dff2b2af239a6386d860881989de50f7a4fb6ae5b402c6dfe828308bbf4ccc2b6f616fdfc2b445fe23fbfcc302163b320813b50fa27940e578b5145345c WHIRLPOOL af4827f4514acc8380f312a72bb3208614f1f529e7373bca3bb610315e0474c9d7c7cbda1338d7019316e708f17ba73e71539092065041df588fd449f7639b54
diff --git a/sys-fs/bedup/bedup-0.10.0.ebuild b/sys-fs/bedup/bedup-0.10.0.ebuild
new file mode 100644
index 000000000000..da05f0fc09d1
--- /dev/null
+++ b/sys-fs/bedup/bedup-0.10.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Btrfs file de-duplication tool"
+HOMEPAGE="https://github.com/g2p/bedup"
+SRC_URI="https://github.com/g2p/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# we need btrfs-progs with includes installed.
+DEPEND=">=dev-python/cffi-0.5:=[${PYTHON_USEDEP}]
+ >=sys-fs/btrfs-progs-0.20_rc1_p358"
+RDEPEND="${DEPEND}
+ dev-python/alembic[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.8.2[sqlite,${PYTHON_USEDEP}]"
diff --git a/sys-fs/bedup/bedup-9999.ebuild b/sys-fs/bedup/bedup-9999.ebuild
index 9f4323451a29..b5ae24edd7dd 100644
--- a/sys-fs/bedup/bedup-9999.ebuild
+++ b/sys-fs/bedup/bedup-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{3_3,3_4} )
#if LIVE
EGIT_REPO_URI="git://github.com/g2p/bedup.git
@@ -12,11 +12,12 @@ EGIT_REPO_URI="git://github.com/g2p/bedup.git
inherit git-r3
#endif
-inherit distutils-r1
+inherit distutils-r1 vcs-snapshot
DESCRIPTION="Btrfs file de-duplication tool"
HOMEPAGE="https://github.com/g2p/bedup"
-SRC_URI="https://github.com/g2p/${PN}/archive/v${PV}.tar.gz"
+SRC_URI="https://github.com/g2p/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
@@ -27,12 +28,13 @@ IUSE=""
DEPEND=">=dev-python/cffi-0.5:=[${PYTHON_USEDEP}]
>=sys-fs/btrfs-progs-0.20_rc1_p358"
RDEPEND="${DEPEND}
- <dev-python/alembic-0.7[${PYTHON_USEDEP}]
- dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/alembic[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
>=dev-python/sqlalchemy-0.8.2[sqlite,${PYTHON_USEDEP}]"
#if LIVE
SRC_URI=
KEYWORDS=
+
+src_unpack() { git-r3_src_unpack; }
#endif