summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2016-02-21 22:11:46 -0600
committerErik Mackdanz <stasibear@gentoo.org>2016-02-21 22:11:46 -0600
commite8a2d184834becddfafa0c2b178a18db5a3814bd (patch)
treedc3dd23d476429872d0d6d3a9113ca37ce04e1b7 /sys-fs
parentapp-misc/tmate: new 2.2.0 added (diff)
downloadgentoo-e8a2d184834becddfafa0c2b178a18db5a3814bd.tar.gz
gentoo-e8a2d184834becddfafa0c2b178a18db5a3814bd.tar.bz2
gentoo-e8a2d184834becddfafa0c2b178a18db5a3814bd.zip
sys-fs/lxcfs: bump to 2.0.0_beta2
Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lxcfs/Manifest1
-rw-r--r--sys-fs/lxcfs/files/lxcfs-2.0.0_beta2.initd27
-rw-r--r--sys-fs/lxcfs/files/lxcfs-2.0.0_beta2.service13
-rw-r--r--sys-fs/lxcfs/lxcfs-2.0.0_beta2.ebuild59
4 files changed, 100 insertions, 0 deletions
diff --git a/sys-fs/lxcfs/Manifest b/sys-fs/lxcfs/Manifest
index 6df659adba35..3a080656851f 100644
--- a/sys-fs/lxcfs/Manifest
+++ b/sys-fs/lxcfs/Manifest
@@ -1,3 +1,4 @@
DIST lxcfs-0.13.tar.gz 35046 SHA256 a0280b1080c95062d75fa0a3f0e743849c7cd8a88b49ff8323a665cbac75224a SHA512 bca32de4857dbcafeca0d206fd202223b35aa5918ffee9d88486cec0d7c686e9b258918204f340f666fb3ac5d382ee84706db4f5268e98c8153e4ccc5de12595 WHIRLPOOL d074d482461e8f98d55f9919eabd98cc6c015fce7f731bb99122c7b16bf40faa37a7c3ffbe2e7aa7375a0313c00e508d79863f1a60e53ab584696fe5abaec5dc
DIST lxcfs-0.16.tar.gz 35307 SHA256 a43c303ec46f4f25b14b7973726b2dc04231a126763b9fe6e0b080d608c04086 SHA512 536b7b6109b2b9d508c37baa1e4824d0cac37eadc2c046f49db89e24adb5474d6a67410e3c0cbb970c73d2dfe7e3757a4ce08577018c2fdb787668ed31af3a03 WHIRLPOOL 718505531388f517b154aff3cca18d5526a9d18163e22e95a5cd496757f3261b2342d52f0de704d9fe7d41d5623099f3c41493cd17668fc74facf2987b27eea5
DIST lxcfs-0.17.tar.gz 40501 SHA256 bcfe14a1ab4b717af1750b04c891a70b59f167d166c2db74984610041c926745 SHA512 dbc38265a65056330e46b8cc56558c6d14e13102c5e6c65a446749f5370c25d70a3a008d22c64b7d435c60e31bbe3efba887fd4f98c0a62fb5ad60c15366b174 WHIRLPOOL af4c0b03ede15414b53670a1363fa240986252b0ad1de8b0e13f99150ef4b2d419f63b6f96e94015344665c118c8599e1e97fb94854be89fc884ba40b96ec2c0
+DIST lxcfs-2.0.0_beta2.tar.gz 44421 SHA256 4eacbbb51031ebd0776f050d7279b2076f7b4e156503f1bbe88e034f181e1d38 SHA512 d62bccc687873c060f299a726debc4642a0900f7e7a460b5c37dcb0b5d7cb75cd5b98ee03f129ccddbe62085510e1760db73010674333536f7126d01987262f4 WHIRLPOOL 470c6118a5560ff5fd447a409d136453b423d0b27a2f00652316b9415f68e08d349fc0e75edb1d312f7a25709bf96621574bd200c8fc92808a9e4eb59aada971
diff --git a/sys-fs/lxcfs/files/lxcfs-2.0.0_beta2.initd b/sys-fs/lxcfs/files/lxcfs-2.0.0_beta2.initd
new file mode 100644
index 000000000000..a85021401a7d
--- /dev/null
+++ b/sys-fs/lxcfs/files/lxcfs-2.0.0_beta2.initd
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DAEMON=/usr/bin/lxcfs
+PIDFILE=/run/lxcfs.pid
+
+start() {
+ ebegin "Starting lxcfs"
+
+ start-stop-daemon --start \
+ --pidfile ${PIDFILE} \
+ --exec ${DAEMON} \
+ --background \
+ --make-pidfile \
+ -- \
+ -f -o allow_other /var/lib/lxcfs
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping lxcfs"
+ start-stop-daemon --stop --quiet -R TERM/45 -p ${PIDFILE}
+ eend $?
+}
diff --git a/sys-fs/lxcfs/files/lxcfs-2.0.0_beta2.service b/sys-fs/lxcfs/files/lxcfs-2.0.0_beta2.service
new file mode 100644
index 000000000000..ff737c7e78ce
--- /dev/null
+++ b/sys-fs/lxcfs/files/lxcfs-2.0.0_beta2.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=FUSE filesystem for LXC
+ConditionVirtualization=!container
+Before=lxc.service
+
+[Service]
+ExecStart=/usr/bin/lxcfs -f -o allow_other /var/lib/lxcfs
+KillMode=none
+Restart=on-failure
+ExecStop=/usr/bin/fusermount -u /var/lib/lxcfs
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-fs/lxcfs/lxcfs-2.0.0_beta2.ebuild b/sys-fs/lxcfs/lxcfs-2.0.0_beta2.ebuild
new file mode 100644
index 000000000000..f27938250bf6
--- /dev/null
+++ b/sys-fs/lxcfs/lxcfs-2.0.0_beta2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils systemd vcs-snapshot versionator
+DESCRIPTION="FUSE filesystem for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/lxc/lxcfs.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ SRC_URI=""
+ KEYWORDS=""
+else
+ # e.g. upstream is 2.0.0.beta2, we want 2.0.0_beta2
+ UPSTREAM_PV=$(replace_version_separator 3 '.' )
+ SRC_URI="https://github.com/lxc/lxcfs/archive/${PN}-${UPSTREAM_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+#IUSE="test"
+
+# Omit all dbus. Upstream appears to require it because systemd, but
+# lxcfs makes no direct use of dbus.
+RDEPEND="
+ dev-libs/glib:2
+ sys-fs/fuse
+ virtual/pam
+"
+DEPEND="
+ sys-apps/help2man
+ ${RDEPEND}
+"
+
+src_prepare() {
+ ./bootstrap.sh || die "Failed to bootstrap configure files"
+}
+
+src_configure() {
+ econf --localstatedir=/var
+}
+
+# Test suite fails for me
+# src_test() {
+# emake tests
+# tests/main.sh || die "Tests failed"
+# }
+
+src_install() {
+ default
+ dodir /var/lib/lxcfs
+ newinitd "${FILESDIR}"/${P}.initd lxcfs
+ systemd_newunit "${FILESDIR}/${P}.service" lxcfs.service
+}