summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-12-17 16:47:18 +0100
committerJustin Lecher <jlec@gentoo.org>2016-12-17 19:04:15 +0100
commitea03cc4fb804978b09344a9d12c4db066d184150 (patch)
treecee5dfee42373e983f80312a1094c2711700f350 /sys-fs
parentsys-fs/aufs-headers: Bump to latest aufs release (diff)
downloadgentoo-ea03cc4fb804978b09344a9d12c4db066d184150.tar.gz
gentoo-ea03cc4fb804978b09344a9d12c4db066d184150.tar.bz2
gentoo-ea03cc4fb804978b09344a9d12c4db066d184150.zip
sys-fs/aufs4: Bump to latest aufs release
Package-Manager: portage-2.3.3 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/aufs4/Manifest1
-rw-r--r--sys-fs/aufs4/aufs4-0_pre20161219.ebuild185
2 files changed, 186 insertions, 0 deletions
diff --git a/sys-fs/aufs4/Manifest b/sys-fs/aufs4/Manifest
index 6549e51363f5..861374b8af4b 100644
--- a/sys-fs/aufs4/Manifest
+++ b/sys-fs/aufs4/Manifest
@@ -3,3 +3,4 @@ DIST aufs4-standalone-0_pre20160223.tar.xz 1072092 SHA256 46c9e0bb68902fb92028a4
DIST aufs4-standalone-0_pre20160627.tar.xz 1427036 SHA256 47e8fbaef29d62b7d5856103966e254840771d329dc2a181014d43a19629063b SHA512 c2e3d92fc6ca8968071a40d2773b63ec21fdd2bb12e8375dced30279ffcafcd06cacb0c20a6bb5378704c5de670426d0d92149bb5737507e3515b5df648e1b81 WHIRLPOOL 813262655193abf9fc61b993f70c11e052f5803b66ac8fdfcbd4b476ef03e7ae7c7be13520e9c7c3349d1ab89628dabf6b01a81f98ed82082c15515922ab07c5
DIST aufs4-standalone-0_pre20160815.tar.xz 1648360 SHA256 35b2b8c558a9927eb6079055fbe040bc790d31131193afde6270f5cc6dd19603 SHA512 a9a86ce4fce04100704cce1acf04b8eeff6a2b81cc591d3ceeafa736a3a8e8fed59538f9301af6cb3ec496dd914b81a3134669ba8871624b2266cc3f731b9fae WHIRLPOOL 68c6241c7680670e68d2b09fdc8008a90b666c9baf49960785c626637d412811ba12582b62830a49309cc8f2b36a1ff874973ad89eb61b80ed0cf02e58a86a53
DIST aufs4-standalone-0_pre20161010.tar.xz 1635556 SHA256 86d9ba7c401640a990991ca7dbea587ac755253791e0d325ec77ca01730359e3 SHA512 520f47255ee33762f111f93ceeaaee9cf6136c13fb6968a7a7d49388c189e112875f076c5fecdad2123d137a2bc0b74e9c0e6e8913e75dfede30e7a65dd74616 WHIRLPOOL 6b8b1836093ba29bfbf24a6a02231c9514a406d99a5b78bd9db660d388efc9f6e09957b11bc5c3f1f4dc71188a37822e708d48bf5940627881373897b08f3c85
+DIST aufs4-standalone-0_pre20161219.tar.xz 1823772 SHA256 92554aa017279d31c3a3228f32dee70f7dee3cdd105b4f281f16e92900120d24 SHA512 59fc0df19716d8f03e2547d98d6f412e921576d60afd783e5691a07c09b298ee61f491501e07ec154665a56d11b1887f94813ef5972254e6391251a48ba156c9 WHIRLPOOL 8470f594e6ebb6d56da9b4c20d1b372a77aac2e0b7e009e15f76d082b8ad51b287ccc1da7f64cbcb4d513af4780795b811dea1b1f953e306bb23d56a72453a36
diff --git a/sys-fs/aufs4/aufs4-0_pre20161219.ebuild b/sys-fs/aufs4/aufs4-0_pre20161219.ebuild
new file mode 100644
index 000000000000..3e3c7af7b03d
--- /dev/null
+++ b/sys-fs/aufs4/aufs4-0_pre20161219.ebuild
@@ -0,0 +1,185 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils flag-o-matic linux-info linux-mod multilib readme.gentoo-r1 toolchain-funcs
+
+AUFS_VERSION="${PV%%_p*}"
+# highest branch version
+PATCH_MAX_VER=8
+# highest supported version
+KERN_MAX_VER=9
+# lowest supported version
+KERN_MIN_VER=0
+
+DESCRIPTION="An entirely re-designed and re-implemented Unionfs"
+HOMEPAGE="http://aufs.sourceforge.net/"
+SRC_URI="https://dev.gentoo.org/~jlec/distfiles/aufs4-standalone-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc fuse hfs inotify kernel-patch nfs pax_kernel ramfs"
+
+DEPEND="
+ dev-util/patchutils
+ dev-vcs/git"
+RDEPEND="
+ sys-fs/aufs-util
+ !sys-fs/aufs
+ !sys-fs/aufs2
+ !sys-fs/aufs3"
+
+S="${WORKDIR}"/${PN}-standalone
+
+MODULE_NAMES="aufs(misc:${S})"
+
+pkg_setup() {
+ CONFIG_CHECK+=" !AUFS_FS"
+ use inotify && CONFIG_CHECK+=" ~FSNOTIFY"
+ use nfs && CONFIG_CHECK+=" EXPORTFS"
+ use fuse && CONFIG_CHECK+=" ~FUSE_FS"
+ use hfs && CONFIG_CHECK+=" ~HFSPLUS_FS"
+ use pax_kernel && CONFIG_CHECK+=" PAX" \
+ && ERROR_PAX="Please use hardened sources"
+
+ # this is needed so merging a binpkg ${PN} is
+ # possible w/out a kernel unpacked on the system
+ [[ -n "$PKG_SETUP_HAS_BEEN_RAN" ]] && return
+
+ get_version
+ kernel_is lt 4 ${KERN_MIN_VER} 0 && \
+ die "the kernel version isn't supported by upstream anymore. Please upgrade."
+ kernel_is gt 4 ${KERN_MAX_VER} 99 && die "kernel too new"
+
+ linux-mod_pkg_setup
+
+ if [[ "${KV_MINOR}" -gt "${PATCH_MAX_VER}" ]]; then
+ PATCH_BRANCH="x-rcN"
+ elif [[ "${KV_MINOR}" == "1" ]] && [[ "${KV_PATCH}" -ge "13" ]]; then
+ PATCH_BRANCH="${KV_MINOR}".13+
+ else
+ PATCH_BRANCH="${KV_MINOR}"
+ fi
+
+ case ${KV_EXTRA} in
+ "")
+ elog "It seems you are using vanilla-sources with aufs4"
+ elog "Please use sys-kernel/aufs-sources with USE=vanilla"
+ elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
+ ;;
+ "-gentoo")
+ elog "It seems you are using gentoo-sources with aufs4"
+ elog "Please use sys-kernel/aufs-sources"
+ elog "This will save you the nasty reemerge of sys-fs/aufs4 on every kernel upgrade"
+ ;;
+ esac
+
+ pushd "${T}" &> /dev/null || die
+ unpack ${A}
+
+ cd ${PN}-standalone || die
+
+ local module_branch=origin/${PN}.${PATCH_BRANCH}
+
+ einfo "Using ${module_branch} as patch source"
+ git checkout -q -b local-${PN}.${PATCH_BRANCH} ${module_branch} || die
+
+ combinediff \
+ ${PN}-base.patch ${PN}-standalone.patch > "${T}"/combined-1.patch
+ combinediff \
+ "${T}"/combined-1.patch ${PN}-mmap.patch \
+ > ${PN}-standalone-base-mmap-combined.patch
+
+ if ! ( patch -p1 --dry-run --force -R -d ${KV_DIR} < ${PN}-standalone-base-mmap-combined.patch > /dev/null ); then
+ if use kernel-patch; then
+ cd ${KV_DIR}
+ ewarn "Patching your kernel..."
+ patch \
+ --no-backup-if-mismatch --force -p1 -R -d ${KV_DIR} \
+ < "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch \
+ > /dev/null
+ epatch "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
+ ewarn "You need to compile your kernel with the applied patch"
+ ewarn "to be able to load and use the aufs kernel module"
+ else
+ eerror "You need to apply a patch to your kernel to compile and run the ${PN} module"
+ eerror "Either enable the kernel-patch useflag to do it with this ebuild"
+ eerror "or apply "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch by hand"
+ die "missing kernel patch, please apply it first"
+ fi
+ fi
+
+ popd &> /dev/null
+ export PKG_SETUP_HAS_BEEN_RAN=1
+}
+
+set_config() {
+ for option in $*; do
+ grep -q "^CONFIG_AUFS_${option} =" config.mk || \
+ die "${option} is not a valid config option"
+ sed "/^CONFIG_AUFS_${option}/s:=:= y:g" -i config.mk || die
+ done
+}
+
+src_prepare() {
+ local module_branch=origin/${PN}.${PATCH_BRANCH}
+
+ einfo "Using for module creation branch ${module_branch}"
+ git checkout -q -b local-gentoo ${module_branch} || die
+
+ # All config options to off
+ sed "s:= y:=:g" -i config.mk || die
+
+ set_config RDU BRANCH_MAX_127 SBILIST
+
+ use debug && set_config DEBUG
+ use fuse && set_config BR_FUSE POLL
+ use hfs && set_config BR_HFSPLUS
+ use inotify && set_config HNOTIFY HFSNOTIFY
+ use nfs && set_config EXPORT
+ use nfs && ( use amd64 || use ppc64 ) && set_config INO_T_64
+ use ramfs && set_config BR_RAMFS
+
+ use pax_kernel && epatch "${FILESDIR}"/pax-4.patch
+
+ sed \
+ -e "s:aufs.ko usr/include/linux/aufs_type.h:aufs.ko:g" \
+ -i Makefile || die
+
+ eapply_user
+}
+
+src_compile() {
+ local ARCH=x86
+
+ emake \
+ CC=$(tc-getCC) \
+ LD=$(tc-getLD) \
+ LDFLAGS="$(raw-ldflags)" \
+ ARCH=$(tc-arch-kernel) \
+ CONFIG_AUFS_FS=m \
+ KDIR="${KV_OUT_DIR}"
+}
+
+src_install() {
+ linux-mod_src_install
+
+ use doc && dodoc -r Documentation
+
+ use kernel-patch || \
+ doins "${T}"/${PN}-standalone/${PN}-standalone-base-mmap-combined.patch
+
+ dodoc \
+ Documentation/filesystems/aufs/README \
+ "${T}"/${PN}-standalone/{aufs4-loopback,vfs-ino,tmpfs-idr}.patch
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ linux-mod_pkg_postinst
+}