summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-08-27 01:32:02 -0400
committerMike Frysinger <vapier@gentoo.org>2015-08-27 01:32:42 -0400
commitf99636c6a395f28164bddaeb38d0a96380998ad2 (patch)
tree06bcb000951b87d5acba7f58ce967cd6b7e5e75f /sys-fs
parentsys-fs/mtd-utils: drop old (diff)
downloadgentoo-f99636c6a395f28164bddaeb38d0a96380998ad2.tar.gz
gentoo-f99636c6a395f28164bddaeb38d0a96380998ad2.tar.bz2
gentoo-f99636c6a395f28164bddaeb38d0a96380998ad2.zip
sys-fs/mtd-utils: version bump to 1.5.2
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mtd-utils/Manifest1
-rw-r--r--sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-fs/mtd-utils/Manifest b/sys-fs/mtd-utils/Manifest
index 26eb11d0609d..3d3957245a96 100644
--- a/sys-fs/mtd-utils/Manifest
+++ b/sys-fs/mtd-utils/Manifest
@@ -1,2 +1,3 @@
DIST mtd-utils-1.5.0.tar.gz 336791 SHA256 37c660830010910c75baf4bb92697b99bdef1a63be31630882f9ebdb9347c420 SHA512 d5be5fdf4e34b553b37486c36c786e1eb8f472660c35a6adfd1305045530a270388aae4da8df34d65138469ccb576d72f2791234a4c00d1fdbacdf680d361c5a WHIRLPOOL 0c66f31baa4e54b0e1430632270425ecba0da9a0e61ff09a90a8c2a668a9194c71ab2e775da29b597aac398d6e6e1069d13524f05d121c8a480184cc7687ec11
DIST mtd-utils-1.5.1.tar.gz 341326 SHA256 c3c5765c9f8d2a0b505f4114264c70214984dcda60b0887f480bd9ed5a9d8015 SHA512 7b11dabec26db1187ce9a39f5187998bce9a2ae4e3b99c6ce230dee826cb7576f69885f2125c7e833b229ab7feb0ef18d19ce4bf63dad48c0126586b121183ab WHIRLPOOL 3c79c8d441f2cd872e36897fe641e427c4bdacd2d16396e87ecb2ef95732b1ea903a003f15ab224343002ba99c5e87ce05978a2136070c3aa8e9d2168a90915b
+DIST mtd-utils-1.5.2.tar.gz 343843 SHA256 8169e2860f63f3c216ba830c943139d00995fd030313079cc143bbad24ecf6c3 SHA512 81eb5cf27814234af65409fe93798ec50d9f733978dc606bd33e63d98eb99afb3f988df47dc66a9368a11baee0a35fa1d0d6677af8c23428919e34bd11a25697 WHIRLPOOL e5aa4a15f334222980469a9d002e5f1030510d9ebb46fa6221acf1a70632a68625cb6eb0927a949ebd6a0d2e92c1a51671da21c37386bed389d5f9859c978fc5
diff --git a/sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild b/sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild
new file mode 100644
index 000000000000..26c0a62d42d7
--- /dev/null
+++ b/sys-fs/mtd-utils/mtd-utils-1.5.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils vcs-snapshot
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.infradead.org/mtd-utils.git"
+
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ if [[ ${PV} == *.*.* ]] ; then
+ MY_PV="${PV}-*"
+ SRC_URI="http://git.infradead.org/mtd-utils.git/snapshot/v${PV}.tar.gz -> ${P}.tar.gz"
+ else
+ MY_PV="${PV}-02ae0aac87576d07202a62d11294ea55b56f450b"
+ SRC_URI="mirror://gentoo/${PN}-snapshot-${MY_PV}.tar.xz"
+ fi
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+fi
+
+DESCRIPTION="MTD userspace tools (NFTL, JFFS2, NAND, FTL, UBI)"
+HOMEPAGE="http://git.infradead.org/?p=mtd-utils.git;a=summary"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="xattr"
+
+# We need libuuid
+RDEPEND="!sys-fs/mtd
+ dev-libs/lzo
+ sys-libs/zlib
+ >=sys-apps/util-linux-2.16"
+# ACL is only required for the <sys/acl.h> header file to build mkfs.jffs2
+# And ACL brings in Attr as well.
+DEPEND="${RDEPEND}
+ xattr? ( sys-apps/acl )"
+
+makeopts() {
+ # These affect build output, so keep it common between compile & install.
+ echo CROSS=${CHOST}- V=1
+ use xattr || echo WITHOUT_XATTR=1
+}
+
+src_compile() {
+ tc-export AR CC RANLIB
+ local compileopts=(
+ AR="${AR}" CC="${CC}" RANLIB="${RANLIB}"
+ )
+ emake $(makeopts) "${compileopts[@]}"
+}
+
+src_install() {
+ emake $(makeopts) install DESTDIR="${ED}"
+ dodoc *.txt
+ newdoc mkfs.ubifs/README README.mkfs.ubifs
+ # TODO: check ubi-utils for docs+scripts
+}