summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-infiniband/srptools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-infiniband/srptools')
-rw-r--r--sys-infiniband/srptools/Manifest2
-rw-r--r--sys-infiniband/srptools/files/srpd.initd42
-rw-r--r--sys-infiniband/srptools/metadata.xml11
-rw-r--r--sys-infiniband/srptools/srptools-0.0.4-r2.ebuild30
-rw-r--r--sys-infiniband/srptools/srptools-1.0.2.ebuild29
5 files changed, 114 insertions, 0 deletions
diff --git a/sys-infiniband/srptools/Manifest b/sys-infiniband/srptools/Manifest
new file mode 100644
index 000000000000..ca457c585395
--- /dev/null
+++ b/sys-infiniband/srptools/Manifest
@@ -0,0 +1,2 @@
+DIST OFED-3.12-rc1.tgz 22055476 SHA256 14ca8a2b0d68e3ee9a37f475fa9eecd9a5ffd6055135f9d4d9db8319843a94dc SHA512 9f834d6982ab7e8ab47a8b5c958ab2e4c238ef983e47798e7f06655f69672ea1e996297939b381f26ed8c39552f6e62156173d5ddd2f0a7b6cad6aecdd973944 WHIRLPOOL 5a64b1d952890ea0e72e0ca93654a0fabc8f871475b05fcbe3b214ddfe4836f6b92d4fbc9e0f0d79acfe69d8c8d219b2c467c23654021e23eaf85ae6825ea4a9
+DIST OFED-3.5-rc2.tgz 18600237 SHA256 b267cea49bf72790843e6b08e26c10a6954d7736a8b93deed1e632772f4f5fff SHA512 deb83c3417ac60bd5d4c6ac1cadf93d6a34a55ca58365b54bb0c3a8230ba6a7f13e0257515dac0170cc4ab46b558519c86e6c01f7fa49550162feed0b0ea2e89 WHIRLPOOL e6843593fbe4937ffcf600be9cb3dee78e14cbeb4c411a4b64076b1194653cbcb9d4bc6cbd52ad77ac9c6b14d4dd2cdafa4364bfe6924b55896844042aa4d9cd
diff --git a/sys-infiniband/srptools/files/srpd.initd b/sys-infiniband/srptools/files/srpd.initd
new file mode 100644
index 000000000000..3588a4039306
--- /dev/null
+++ b/sys-infiniband/srptools/files/srpd.initd
@@ -0,0 +1,42 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+description="SCSI RDMA Protoaemon daemon"
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if ! modinfo ib_srp > /dev/null 2>&1 ; then
+ eerror "ib_srp module not found!"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig
+ ebegin "Loading ib_srp module"
+ modprobe ib_srp
+ eend $?
+ ebegin "Starting srp_daemon"
+ start-stop-daemon \
+ --start \
+ --background \
+ --make-pidfile \
+ --pidfile ${SRP_DAEMON_PID:-/var/run/srpd.pid} \
+ --exec /usr/sbin/srp_daemon -- ${SRP_DAEMON_OPTS:- -e -R 60}
+ eend $?
+
+}
+
+stop() {
+ ebegin "Stopping srp_daemon"
+ start-stop-daemon --stop --pidfile ${SRP_DAEMON_PID:-/var/run/srpd.pid}
+ eend $?
+ ebegin "Unloading ib_srp module"
+ rmmod ib_srp
+ eend $?
+}
diff --git a/sys-infiniband/srptools/metadata.xml b/sys-infiniband/srptools/metadata.xml
new file mode 100644
index 000000000000..68d6e02a66c8
--- /dev/null
+++ b/sys-infiniband/srptools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cluster</herd>
+ <longdescription>
+srptools is a package of tools for discovering and connecting to SRP
+SCSI targets on InfiniBand fabrics. These targets can be accessed
+with the InfiniBand SRP initiator module, "ib_srp," included in Linux
+kernels 2.6.15 and newer.
+</longdescription>
+</pkgmetadata>
diff --git a/sys-infiniband/srptools/srptools-0.0.4-r2.ebuild b/sys-infiniband/srptools/srptools-0.0.4-r2.ebuild
new file mode 100644
index 000000000000..09e617260f20
--- /dev/null
+++ b/sys-infiniband/srptools/srptools-0.0.4-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+OFED_VER="3.5"
+OFED_RC="1"
+OFED_RC_VER="2"
+OFED_SUFFIX="0.1.gce1f64c"
+OFED_SNAPSHOT="1"
+
+inherit openib
+
+DESCRIPTION="Tools for discovering and connecting to SRP CSI targets on InfiniBand fabrics"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND="
+ sys-infiniband/libibverbs:${SLOT}
+ sys-infiniband/libibumad:${SLOT}
+ "
+RDEPEND="${DEPEND}"
+block_other_ofed_versions
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/srpd.initd" srpd
+}
diff --git a/sys-infiniband/srptools/srptools-1.0.2.ebuild b/sys-infiniband/srptools/srptools-1.0.2.ebuild
new file mode 100644
index 000000000000..e5870d22c4c4
--- /dev/null
+++ b/sys-infiniband/srptools/srptools-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+OFED_VER="3.12"
+OFED_RC="1"
+OFED_RC_VER="1"
+OFED_SUFFIX="1"
+
+inherit openib
+
+DESCRIPTION="Tools for discovering and connecting to SRP CSI targets on InfiniBand fabrics"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE=""
+
+DEPEND="
+ sys-infiniband/libibverbs:${SLOT}
+ sys-infiniband/libibumad:${SLOT}
+ "
+RDEPEND="${DEPEND}"
+block_other_ofed_versions
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/srpd.initd" srpd
+}