summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkuzetsa <kuzetsa@gmail.com>2018-07-17 01:09:02 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2018-07-17 17:34:17 -0400
commit9e6554be741c77f6b809e3eda752bb0c8fb92c05 (patch)
tree3d7a9ad34491512158ba8922c081da91409d5449 /sys-kernel/ck-sources/ck-sources-4.14.55.ebuild
parentsys-kernel/ck-sources: genpatches-4.9-115 (diff)
downloadgentoo-9e6554be741c77f6b809e3eda752bb0c8fb92c05.tar.gz
gentoo-9e6554be741c77f6b809e3eda752bb0c8fb92c05.tar.bz2
gentoo-9e6554be741c77f6b809e3eda752bb0c8fb92c05.zip
sys-kernel/ck-sources: genpatches-4.14-60
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-kernel/ck-sources/ck-sources-4.14.55.ebuild')
-rw-r--r--sys-kernel/ck-sources/ck-sources-4.14.55.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-4.14.55.ebuild b/sys-kernel/ck-sources/ck-sources-4.14.55.ebuild
new file mode 100644
index 000000000000..ebb049bc2331
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-4.14.55.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches/
+ http://kernel.kolivas.org/"
+
+IUSE="experimental"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="60"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 kernel-2
+detect_version
+detect_arch
+
+DEPEND="deblob? ( ${PYTHON_DEPS} )"
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Con Kolivas' high performance patchset and Gentoo's genpatches for Linux ${K_BRANCH_ID}"
+
+CK_VERSION="1"
+
+CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}.xz"
+
+CK_BASE_URL="http://ck.kolivas.org/patches/4.0"
+CK_LVER_URL="${CK_BASE_URL}/${K_BRANCH_ID}/${K_BRANCH_ID}-ck${CK_VERSION}"
+CK_URI="${CK_LVER_URL}/${CK_FILE}"
+
+# Fix for: https://github.com/gentoo/gentoo/pull/6942
+BLKIO_HASH="25849740d77dfc089fdbfb53623e50d38a972aff"
+BLKIO_FILE="${PN}-4.14-blkio-fix.patch"
+BLKIO_URI="https://github.com/ckolivas/linux/commit/${BLKIO_HASH}.patch -> ${BLKIO_FILE}"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI} ${BLKIO_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${CK_FILE} ${DISTDIR}/${BLKIO_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_setup() {
+ use deblob && python-any-r1_pkg_setup
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+
+#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------
+
+ # linux-info eclass cannot handle recursively expanded variables in Makefile #490328
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile" || die
+
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ elog "ck-sources previously enabled CPU optimizations by default."
+ elog "USE=\"experimental\" is now required to enable this patch."
+ elog "this can be set in /etc/portage/package.use (or make.conf)"
+}