summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-09-18 15:36:42 -0400
committerMike Gilbert <floppym@gentoo.org>2016-09-18 16:04:55 -0400
commitd2ad3fdc1960d9a9279e3cf089dba37ddf27354e (patch)
treef919767d349ac7b00ee0f111ae947a4fadb73a48 /sys-kernel/ck-sources
parentsys-kernel/hardened-sources: EAPI 6 -> 5 (diff)
downloadgentoo-d2ad3fdc1960d9a9279e3cf089dba37ddf27354e.tar.gz
gentoo-d2ad3fdc1960d9a9279e3cf089dba37ddf27354e.tar.bz2
gentoo-d2ad3fdc1960d9a9279e3cf089dba37ddf27354e.zip
sys-kernel/ck-sources: drop EAPI 6 ebuild
kernel-2.eclass is not ready for EAPI 6. Package-Manager: portage-2.3.0_p31
Diffstat (limited to 'sys-kernel/ck-sources')
-rw-r--r--sys-kernel/ck-sources/ck-sources-4.3.6-r1.ebuild91
1 files changed, 0 insertions, 91 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-4.3.6-r1.ebuild b/sys-kernel/ck-sources/ck-sources-4.3.6-r1.ebuild
deleted file mode 100644
index f0a50e587917..000000000000
--- a/sys-kernel/ck-sources/ck-sources-4.3.6-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="6"
-ETYPE="sources"
-KEYWORDS="~amd64 ~x86"
-
-HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches/
- http://users.tpg.com.au/ckolivas/kernel/"
-
-K_WANT_GENPATCHES="base extras experimental"
-K_EXP_GENPATCHES_PULL="1"
-K_EXP_GENPATCHES_NOUSE="1"
-K_GENPATCHES_VER="8"
-K_SECURITY_UNSUPPORTED="1"
-K_DEBLOB_AVAILABLE="1"
-
-inherit kernel-2
-detect_version
-detect_arch
-
-K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
-
-DESCRIPTION="Con Kolivas' high performance patchset and Gentoo's genpatches for Linux ${K_BRANCH_ID}"
-
-#-- If Gentoo-Sources don't follow then extra incremental patches are needed -
-
-XTRA_INCP_MIN=""
-XTRA_INCP_MAX=""
-
-#--
-
-CK_VERSION="3"
-
-CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}.xz"
-
-CK_BASE_URL="http://ck.kolivas.org/patches/4.0"
-CK_LVER_URL="${CK_BASE_URL}/${K_BRANCH_ID}/${K_BRANCH_ID}-ck${CK_VERSION}"
-CK_URI="${CK_LVER_URL}/${CK_FILE}"
-
-#-- Build extra incremental patches list --------------------------------------
-
-LX_INCP_URI=""
-LX_INCP_LIST=""
-if [ -n "${XTRA_INCP_MIN}" ]; then
- LX_INCP_URL="${KERNEL_BASE_URI}/incr"
- for i in `seq ${XTRA_INCP_MIN} ${XTRA_INCP_MAX}`; do
- LX_INCP[i]="patch-${K_BRANCH_ID}.${i}-$(($i+1)).bz2"
- LX_INCP_URI="${LX_INCP_URI} ${LX_INCP_URL}/${LX_INCP[i]}"
- LX_INCP_LIST="${LX_INCP_LIST} ${DISTDIR}/${LX_INCP[i]}"
- done
-fi
-
-#-- CK needs sometimes to patch itself... ---------------------------
-
-CK_INCP_URI=""
-CK_INCP_LIST=""
-
-#-- Local patches needed for the ck-patches to apply smoothly -------
-
-PRE_CK_FIX=""
-POST_CK_FIX=""
-
-#--
-
-SRC_URI="${KERNEL_URI} ${LX_INCP_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_INCP_URI} ${CK_URI}"
-
-UNIPATCH_LIST="${LX_INCP_LIST} ${PRE_CK_FIX} ${DISTDIR}/${CK_FILE} ${CK_INCP_LIST} ${POST_CK_FIX}"
-UNIPATCH_STRICTORDER="yes"
-
-#-- Since experimental genpatches && we want BFQ irrespective of experimental -
-
-K_EXP_GENPATCHES_LIST="50*_*.patch*"
-
-src_prepare() {
- default
-
-#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------
-
- sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile"
-}
-
-pkg_postinst() {
-
- kernel-2_pkg_postinst
-
- elog
- elog "For more info on this patchset, see: https://forums.gentoo.org/viewtopic-t-941030-start-0.html"
- elog
-}