summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-kernel/genkernel-next/genkernel-next-35.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-kernel/genkernel-next/genkernel-next-35.ebuild')
-rw-r--r--sys-kernel/genkernel-next/genkernel-next-35.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-kernel/genkernel-next/genkernel-next-35.ebuild b/sys-kernel/genkernel-next/genkernel-next-35.ebuild
new file mode 100644
index 000000000000..d63b31531526
--- /dev/null
+++ b/sys-kernel/genkernel-next/genkernel-next-35.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ "${PV}" != "9999" ]]; then
+ SRC_URI="http://dev.gentoo.org/~lxnay/genkernel-next/${P}.tar.xz"
+else
+ EGIT_REPO_URI="git://github.com/Sabayon/genkernel-next.git"
+ inherit git-2
+fi
+inherit bash-completion-r1 eutils
+
+if [[ "${PV}" == "9999" ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha amd64 ~arm ia64 x86"
+fi
+
+DESCRIPTION="Gentoo automatic kernel building scripts, reloaded"
+HOMEPAGE="http://www.gentoo.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+RESTRICT=""
+IUSE="cryptsetup dmraid gpg iscsi plymouth selinux"
+
+DEPEND="app-text/asciidoc
+ sys-fs/e2fsprogs
+ selinux? ( sys-libs/libselinux )"
+RDEPEND="${DEPEND}
+ !sys-kernel/genkernel
+ cryptsetup? ( sys-fs/cryptsetup )
+ dmraid? ( >=sys-fs/dmraid-1.0.0_rc16 )
+ gpg? ( app-crypt/gnupg )
+ iscsi? ( sys-block/open-iscsi )
+ plymouth? ( sys-boot/plymouth )
+ app-portage/portage-utils
+ app-arch/cpio
+ >=app-misc/pax-utils-0.6
+ !<sys-apps/openrc-0.9.9
+ sys-apps/util-linux
+ sys-block/thin-provisioning-tools
+ sys-fs/lvm2"
+
+src_prepare() {
+ sed -i "/^GK_V=/ s:GK_V=.*:GK_V=${PV}:g" "${S}/genkernel" || \
+ die "Could not setup release"
+
+ epatch_user
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ doman "${S}"/genkernel.8 || die "doman"
+ dodoc "${S}"/AUTHORS || die "dodoc"
+
+ newbashcomp "${S}"/genkernel.bash "${PN}"
+}