summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2016-06-08 09:21:09 -0400
committerMike Pagano <mpagano@gentoo.org>2016-06-08 09:21:19 -0400
commitc18c4108f2e19b86da0caec0a092d321c4fdf043 (patch)
tree0da38470f5e96b59273706679fe3eb73e174778b /sys-kernel/gentoo-sources/gentoo-sources-4.1.26.ebuild
parentx11-libs/snorenotify: amd64/x86 stable (diff)
downloadgentoo-c18c4108f2e19b86da0caec0a092d321c4fdf043.tar.gz
gentoo-c18c4108f2e19b86da0caec0a092d321c4fdf043.tar.bz2
gentoo-c18c4108f2e19b86da0caec0a092d321c4fdf043.zip
sys-kernel/gentoo-sources: Linux patch 4.1.26
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-4.1.26.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.1.26.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.1.26.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.1.26.ebuild
new file mode 100644
index 000000000000..d26378f69e27
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.1.26.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="31"
+K_DEBLOB_AVAILABLE="0"
+K_KDBUS_AVAILABLE="0"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 -hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}