summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-07-18 07:47:41 -0400
committerMike Pagano <mpagano@gentoo.org>2018-07-18 07:47:52 -0400
commitb6bd9ef1b3095560953da4481c0e77dbb8cfcc79 (patch)
tree51fc3086878a59a1f3f99a627156182514f704f8 /sys-kernel/gentoo-sources/gentoo-sources-4.17.8.ebuild
parentsys-cluster/kube-proxy: Remove old (diff)
downloadgentoo-b6bd9ef1b3095560953da4481c0e77dbb8cfcc79.tar.gz
gentoo-b6bd9ef1b3095560953da4481c0e77dbb8cfcc79.tar.bz2
gentoo-b6bd9ef1b3095560953da4481c0e77dbb8cfcc79.zip
sys-kernel/gentoo-sources: Linux patch 4.17.8
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-4.17.8.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-4.17.8.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-4.17.8.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-4.17.8.ebuild
new file mode 100644
index 000000000000..c73638f7769a
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-4.17.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="9"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}