summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-03-04 09:08:55 -0500
committerMike Pagano <mpagano@gentoo.org>2019-03-04 09:09:01 -0500
commit50f25752911b68ad6d97b6b9aebdb780d2fb713b (patch)
tree77bfe6f3f81dd5b9d6500e63332f95bf15669551 /sys-kernel/gentoo-sources/gentoo-sources-5.0.0.ebuild
parentwww-client/vivaldi: Old (diff)
downloadgentoo-50f25752911b68ad6d97b6b9aebdb780d2fb713b.tar.gz
gentoo-50f25752911b68ad6d97b6b9aebdb780d2fb713b.tar.bz2
gentoo-50f25752911b68ad6d97b6b9aebdb780d2fb713b.zip
sys-kernel/gentoo-sources: Linux patch 5.0 and genpatches
Patch to support for namespace user.pax.* on tmpfs. Enable link security restrictions by default. Add UAS disable quirk. See bug #640082. hid-apple patch to enable swapping of the FN and left Control keys and on some apple keyboards. See bug #622902. optimizations for additional CPUs. CPU optimization patch for gcc < v8. CPU optimization patch for >= gcc v8. Signed-off-by: Mike Pagano <mpagano@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-kernel/gentoo-sources/gentoo-sources-5.0.0.ebuild')
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-5.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-5.0.0.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-5.0.0.ebuild
new file mode 100644
index 000000000000..8784f9e16719
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-5.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+
+DESCRIPTION="Full sources including the Gentoo patchset for the ${KV_MAJOR}.${KV_MINOR} kernel tree"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}