summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2018-11-25 18:32:29 -0500
committerMike Pagano <mpagano@gentoo.org>2018-11-25 18:32:38 -0500
commitfbb33b61e1b25a1f04af2ae26d23ac2def8f4c01 (patch)
treebe0403b5d5f851af7ca59cfa73a2c09ad0bcc3d5 /sys-kernel/git-sources/git-sources-4.20_rc4.ebuild
parentmedia-sound/supercollider: Fix usex call (diff)
downloadgentoo-fbb33b61e1b25a1f04af2ae26d23ac2def8f4c01.tar.gz
gentoo-fbb33b61e1b25a1f04af2ae26d23ac2def8f4c01.tar.bz2
gentoo-fbb33b61e1b25a1f04af2ae26d23ac2def8f4c01.zip
sys-kernel/git-sources: Linux patch 4.20-rc4
Signed-off-by: Mike Pagano <mpagano@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-kernel/git-sources/git-sources-4.20_rc4.ebuild')
-rw-r--r--sys-kernel/git-sources/git-sources-4.20_rc4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/git-sources-4.20_rc4.ebuild b/sys-kernel/git-sources/git-sources-4.20_rc4.ebuild
new file mode 100644
index 000000000000..54e27e6f6a7e
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.20_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.19"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}