summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2018-01-15 17:07:16 +0900
committerAlice Ferrazzi <alicef@gentoo.org>2018-01-15 17:07:16 +0900
commitb47d5aa3c63f38198b77fd84a570d789daec9903 (patch)
tree21dadc641734b4f95a0b8953c42224058ba80de4 /sys-kernel/git-sources
parentdev-ruby/fakefs: add 0.13.0 (diff)
downloadgentoo-b47d5aa3c63f38198b77fd84a570d789daec9903.tar.gz
gentoo-b47d5aa3c63f38198b77fd84a570d789daec9903.tar.bz2
gentoo-b47d5aa3c63f38198b77fd84a570d789daec9903.zip
sys-kernel/git-sources: bump to 4.15_rc8
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.15_rc8.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 4a000d2285c7..a6068d5f86c8 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -6,3 +6,4 @@ DIST patch-4.15-rc4.patch 45578434 BLAKE2B cddb2beb403d3cbd0d0d98218dad90078fba9
DIST patch-4.15-rc5.patch 45928364 BLAKE2B 0e798993916680abae0ec40c4bc3128b4b79fd267a6c22448e2cf4bf574aed1b923681a406cf9f48ea1902df2a95f0962d8a300402cccb7dfc1fb9932c9fb6fa SHA512 90d19f5d373e9368d6346c047754a0cdc6e53072da63a533a49cadc8a7ed14e6eebfe109d8be6642f820398626a25d6e75577fcf59e9a9902c4e959fcc470604
DIST patch-4.15-rc6.patch 46146258 BLAKE2B 7a71a6e995aaa104012bb8f2a6e728658a2961d511d5302e7c3de182ae104ea8eafbce2a7b3c7a342ae84cbdee26cf9306fe231b9b92268cc8ed3d7cf562f3f6 SHA512 b68965ef7b78ed9a0547d3a00432b0afaa8441a77412026c84d9b91b751f62d54cb263ec0ffc3547196038f0fe39bdcdfd1e7535776dc8f7a139528ea8ce3dcc
DIST patch-4.15-rc7.patch 46244792 BLAKE2B 80731383db15ebc6aac897b97fe1602ab161f04ca1f3811b47e699d5d50c5e96281672261770c0e8a80f3c0111f6b210104bc67478ccc00cb658cd7d42fb396b SHA512 fae57a83355d3ee0d1b3f07c1af89036f97cb22ab2135a5b57299efb451f3ef91dd8e3822928fb3ad44271508a1ea355771b0e9416d41d25c3888a5074281ade
+DIST patch-4.15-rc8.patch 46486932 BLAKE2B 783cc4fa216d7591a7cf0713cb1aa285017f382c1f6f8c5ebb5a98a5627080854b0f081f7a4417d650c0591ef1878047ebc54cc8ce04763214e861abb74c343d SHA512 30fdd6ad1174f8e3e2b58b80c2796cda502a24153fbdd8852defac552800b4f7baf66c840ec5c3ef4095391b89e6a700e9e5f88e67a2663db4544ac986c2142c
diff --git a/sys-kernel/git-sources/git-sources-4.15_rc8.ebuild b/sys-kernel/git-sources/git-sources-4.15_rc8.ebuild
new file mode 100644
index 000000000000..b525f064fb5d
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.15_rc8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="4.14"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}