summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2021-10-18 09:02:56 +0200
committerAgostino Sarubbo <ago@gentoo.org>2021-10-18 09:02:56 +0200
commite521b92dd338400afb9ce5d2fd72111220845f11 (patch)
tree668de09f6941ceb5c0e30d94b06a9f6f635b5872 /sys-kernel/git-sources
parentdev-perl/Gtk2: x86 stable wrt bug #795300 (diff)
downloadgentoo-e521b92dd338400afb9ce5d2fd72111220845f11.tar.gz
gentoo-e521b92dd338400afb9ce5d2fd72111220845f11.tar.bz2
gentoo-e521b92dd338400afb9ce5d2fd72111220845f11.zip
sys-kernel/git-sources: Automated version bump to 5.15_rc6.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.15_rc6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index ca371f152ef6..3b96530e9376 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -4,3 +4,4 @@ DIST patch-5.15-rc2.patch 41617220 BLAKE2B b2216f798e64ccbcd3d6a9ecbf77388a6af97
DIST patch-5.15-rc3.patch 41945558 BLAKE2B 550064d9cd8b30c062cd4411d169547317a406e259cc46b124a8e6115d2ff4e370903fad3a5bf4e62e9db07fb7d510ecf6c2b36ba27534b813cb379f7fe9c966 SHA512 6e3ae62519dd991d26eee5063d511749d282ad1b8a57d020ee179a5819ed7842f3f22c2ac8ec972f57bb1d4650f46ee3d8a98f52d33c7e82412e4968af2ed3cc
DIST patch-5.15-rc4.patch 42309515 BLAKE2B bb92e0f0fe290faf86da6f0cb4980b1af700d735bb22250851df5c6712af59b82de524cd96f9e3180c4d77121d09258109c16fb48d342e6117073d2ac8189524 SHA512 e5b3c895d72d7c9be5ce409072a3076d5c9789a510e72cd6e5c79011a321a1de219bd84e6ce3df5cba94f4103dbb3c8082e0317b7783138dba05b956737e697c
DIST patch-5.15-rc5.patch 42630582 BLAKE2B fd8402eb398d0e2cdeb88f53b9c9d59e6fef4d0b9474d78e23cc1932738e869c44072483a21dbd4b5b6d4c77a6fb747e12db6f90311ce6040e28eb28a49acbdf SHA512 5646280e7d9da363916697a54c6b759d8e97547dcaa544c1ca24763699dc190c2fb2722f8004541cb347461f0fb4b20d086df184771af884ae50f7efb29ba8fd
+DIST patch-5.15-rc6.patch 42890983 BLAKE2B c2cf4ef6efa367bf4bb5b3488e5ea5771f06b0d80418a88d88d4e7a2674fc3616aa5d75aeed5e092d12d1702cc1961ac3722c299eb542dcb56c766925106169a SHA512 fef30c696159c5649406027bfeebcc83ffb169d0acea05c6b3ef848b070d74eef4834834de7f2a62cf7c218566d7f1a25d79dcb70c934c062e9d6882196a7ec3
diff --git a/sys-kernel/git-sources/git-sources-5.15_rc6.ebuild b/sys-kernel/git-sources/git-sources-5.15_rc6.ebuild
new file mode 100644
index 000000000000..d7e4ec9a1508
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.15_rc6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.14"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}