summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-03 18:06:40 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-03 18:06:55 +0200
commitec062d990138a15042619b01261b467beb10df7b (patch)
tree5a182af8dd0f905b4fe05e8c57594e45efd5fc97 /sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
parentdev-python/cjkwrap: update HOMEPAGE (diff)
downloadgentoo-ec062d990138a15042619b01261b467beb10df7b.tar.gz
gentoo-ec062d990138a15042619b01261b467beb10df7b.tar.bz2
gentoo-ec062d990138a15042619b01261b467beb10df7b.zip
sys-kernel/linux-firmware: manually call mount-boot functions
This is needed because we overwrite these functions in ebuild. Closes: https://bugs.gentoo.org/691350 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-kernel/linux-firmware/linux-firmware-99999999.ebuild')
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-99999999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
index bc18789f40bd..6fd9059b3d55 100644
--- a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
@@ -316,6 +316,8 @@ pkg_preinst() {
if use savedconfig; then
ewarn "USE=savedconfig is active. You must handle file collisions manually."
fi
+
+ mount-boot_pkg_preinst
}
pkg_postinst() {
@@ -332,4 +334,6 @@ pkg_postinst() {
break
fi
done
+
+ mount-boot_pkg_postinst
}