summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-10-30 17:41:55 +0100
committerThomas Deutschmann <whissi@gentoo.org>2020-10-30 17:45:51 +0100
commit2e61b022eaf4c3b25d17c8f6aafe81c34a27bba6 (patch)
tree2048e0ed9a96abbedf3dbeab9de059f2d8a2a9d5 /sys-kernel/linux-firmware
parentsys-kernel/linux-firmware: delete broken symlinks (diff)
downloadgentoo-2e61b022eaf4c3b25d17c8f6aafe81c34a27bba6.tar.gz
gentoo-2e61b022eaf4c3b25d17c8f6aafe81c34a27bba6.tar.bz2
gentoo-2e61b022eaf4c3b25d17c8f6aafe81c34a27bba6.zip
sys-kernel/linux-firmware: always create config file for USE=savedconfig
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-kernel/linux-firmware')
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-99999999.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
index 620398e13c26..63f85a38567c 100644
--- a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
@@ -295,11 +295,10 @@ src_install() {
die "Refusing to install an empty package"
fi
- if use savedconfig; then
- echo "# Remove files that shall not be installed from this list." > "${S}"/${PN}.conf || die
- find * ! -type d >> "${S}"/${PN}.conf || die
- save_config "${S}"/${PN}.conf
- fi
+ # create config file
+ echo "# Remove files that shall not be installed from this list." > "${S}"/${PN}.conf || die
+ find * ! -type d >> "${S}"/${PN}.conf || die
+ save_config "${S}"/${PN}.conf
popd &>/dev/null || die