summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-03-30 21:59:22 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-03-30 22:05:58 +0100
commitea522a707a51675c4b04af0f2d834dc544926850 (patch)
tree931eeeb7d6b10dd740dca8b3cee4a1096bbac7c4 /sys-kernel/linux-headers/linux-headers-5.6.ebuild
parentdev-tcltk/togl: depends on media-libs/mesa[X] (diff)
downloadgentoo-ea522a707a51675c4b04af0f2d834dc544926850.tar.gz
gentoo-ea522a707a51675c4b04af0f2d834dc544926850.tar.bz2
gentoo-ea522a707a51675c4b04af0f2d834dc544926850.zip
sys-kernel/linux-headers: bump up to 5.6
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-5.6.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-5.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-5.6.ebuild b/sys-kernel/linux-headers/linux-headers-5.6.ebuild
new file mode 100644
index 000000000000..af1145d7ef5c
--- /dev/null
+++ b/sys-kernel/linux-headers/linux-headers-5.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+ETYPE="headers"
+H_SUPPORTEDARCH="alpha amd64 arc arm arm64 avr32 cris frv hexagon hppa ia64 m32r m68k metag microblaze mips mn10300 nios2 openrisc ppc ppc64 riscv s390 score sh sparc x86 xtensa"
+inherit kernel-2 toolchain-funcs
+detect_version
+
+PATCH_PV=${PV} # to ease testing new versions against not existing patches
+PATCH_VER="1"
+SRC_URI="${KERNEL_URI}
+ ${PATCH_VER:+mirror://gentoo/gentoo-headers-${PATCH_PV}-${PATCH_VER}.tar.xz}
+ ${PATCH_VER:+https://dev.gentoo.org/~slyfox/distfiles/gentoo-headers-${PATCH_PV}-${PATCH_VER}.tar.xz}
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="app-arch/xz-utils
+ dev-lang/perl"
+RDEPEND=""
+
+S=${WORKDIR}/linux-${PV}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_prepare() {
+ [[ -n ${PATCH_VER} ]] && eapply "${WORKDIR}"/${PATCH_PV}/*.patch
+
+ default
+}
+
+src_install() {
+ kernel-2_src_install
+
+ # hrm, build system sucks
+ find "${ED}" '(' -name '.install' -o -name '*.cmd' ')' -delete
+ find "${ED}" -depth -type d -delete 2>/dev/null
+}
+
+src_test() {
+ emake ARCH=$(tc-arch-kernel) headers_check
+}