summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-02-25 21:00:02 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-02-25 21:00:50 +0200
commit6c4d8e20fc6bd060df2d7cfee0db33bc2ea10ecd (patch)
treedafd23ae9e3e2bef3cea21b7864d63aa672f34cd /sys-kernel/pf-sources
parentsys-cluster/kube-scheduler: 1.15.10 bump (diff)
downloadgentoo-6c4d8e20fc6bd060df2d7cfee0db33bc2ea10ecd.tar.gz
gentoo-6c4d8e20fc6bd060df2d7cfee0db33bc2ea10ecd.tar.bz2
gentoo-6c4d8e20fc6bd060df2d7cfee0db33bc2ea10ecd.zip
sys-kernel/pf-sources: bump to 5.5-pf5
- complete ebuild rewrite / clean up. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.5_p5.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 722d957dae21..d87632525423 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -13,3 +13,4 @@ DIST pf-sources-5.5_p1.patch 551540 BLAKE2B 6e169f1e3a75a9f18b3c8e8c3ab6da9ff365
DIST pf-sources-5.5_p2.patch 657945 BLAKE2B 96acd27211f938605ff14b0588388b78606966e0fdfa7c8168521fd21155db2741d5f8256cb8c5df9232a77a6cf872d2ee945106af5e75502600c45d0d88f660 SHA512 2989554d41c0e970edef4641f7b6a402bd31b48ded6b94fa6b72af356327072a3ea0bcf58b7e9ab953eaf7a555b4cf49dcd75fad58c5da3235f0892f5e06c6ad
DIST pf-sources-5.5_p3.patch 1305735 BLAKE2B 3b124c3fe3949ea18242558d57672f4f9f1e854f0c7351cbfc71ae2783028f7e170df0a8cde55692e87a77915e85decdd91e34105b1685dc0c6718c211d7b596 SHA512 c6915878e5d6347af89ea515ce66b14d3ae511b37774b8e1a277c5154dc9a3398731aa4da838dbf42fe0945000fc329f63a62b60d0b42acc5d1b843c5d614a77
DIST pf-sources-5.5_p4.patch 1489666 BLAKE2B 3906d23f42d4943acf3e75a5b47d94b808417338cffbf8e04dad825387188be678afa3eb7d264c687e483b91b82402370a2df7e72c82294cffc39d4a7c0429b5 SHA512 b0c9cad6a375205c65d32d435efede2dbb98cd6e077aa7ef4d0d33e9735f3937980c371b87a76d5595426b3dce3606bacdb69eb1c8baf14d435e2c9190035bc2
+DIST pf-sources-5.5_p5.patch 2147102 BLAKE2B 0f6aee4d3e59386e3acdf67ab7f931e45acb3d6d1b8aa39a914875da1bde2733d5b4bfc601635280f7f6fd0dcfbf1c6cdd77061a3e4230b128896da829b9e495 SHA512 7d60c3a18bec8642cc13594bdbb82c684d78d62636f9bbb9f2e791f7695476420c6d80256a4157a44e61f9d85c9405dd398587f935c33c77b8a2b92538855037
diff --git a/sys-kernel/pf-sources/pf-sources-5.5_p5.ebuild b/sys-kernel/pf-sources/pf-sources-5.5_p5.ebuild
new file mode 100644
index 000000000000..2a683a5287d4
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.5_p5.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux
+# updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}