summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-03-15 14:34:09 +0100
committerMichael Weber <xmw@gentoo.org>2016-03-15 14:48:27 +0100
commit0364dc90bbaee22ab569bc7602527350f829a279 (patch)
treeb4d79e5ec671a29c6d8cf5bd269eb719df951b40 /sys-kernel/raspberrypi-image
parentsys-kernel/raspberrypi-image: Drop old. (diff)
downloadgentoo-0364dc90bbaee22ab569bc7602527350f829a279.tar.gz
gentoo-0364dc90bbaee22ab569bc7602527350f829a279.tar.bz2
gentoo-0364dc90bbaee22ab569bc7602527350f829a279.zip
sys-kernel/raspberrypi-image: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-kernel/raspberrypi-image')
-rw-r--r--sys-kernel/raspberrypi-image/Manifest1
-rw-r--r--sys-kernel/raspberrypi-image/raspberrypi-image-4.1.19_p20160309.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-image/Manifest b/sys-kernel/raspberrypi-image/Manifest
index bacb97efe086..9fa4abf1b0d9 100644
--- a/sys-kernel/raspberrypi-image/Manifest
+++ b/sys-kernel/raspberrypi-image/Manifest
@@ -1 +1,2 @@
DIST raspberrypi-firmware-1.20160209.tar.gz 114792438 SHA256 ca6a88db72e90ef821b8ca7755bbee9c1d5bdb9a621a45eb029af195d2d29751 SHA512 281092c11d422d821e5e2b0479c3b8f891f8df66cfbf931992902d759c99ed40cbb2d9fada1f944372e5bcd8af69784739e79e9912db3482892b10bf668611f2 WHIRLPOOL 81974a53562ee91544d7a01dc9f4f4173a6e882891f8cf744b700162ddd8f8607b1cfcbbde04cafe2bcea47489f9ea4fd8840adf776e806bef0dba574448e76e
+DIST raspberrypi-firmware-1.20160309.tar.gz 115673896 SHA256 ead0e82b930fdeed9636a6d2d6e07b2512b5f36de3c902da5beaa9328708e181 SHA512 30a6396ef52355c6f6404354645e8d0f5bbf70332b0e1661dfa8ef3456154d07e105d3b7b5bd64efb3e7397fa2fb8c36de1aa78040dc4118060b26949c2ab884 WHIRLPOOL 19a2a28e7dc1403958f12338b5029187bb752f1367f9a46e217b3d91b098960f1cf75efb3610defe3bb2f521559019453cf50a52def3abb9c1ac61419b8ea328
diff --git a/sys-kernel/raspberrypi-image/raspberrypi-image-4.1.19_p20160309.ebuild b/sys-kernel/raspberrypi-image/raspberrypi-image-4.1.19_p20160309.ebuild
new file mode 100644
index 000000000000..7301af3e9fe9
--- /dev/null
+++ b/sys-kernel/raspberrypi-image/raspberrypi-image-4.1.19_p20160309.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="Raspberry PI boot loader and firmware"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+MY_PV="1.20160309"
+SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV} -> raspberrypi-firmware-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="${PVR}"
+KEYWORDS="~arm -*"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}/firmware-${MY_PV}
+
+RESTRICT=""
+
+pkg_preinst() {
+ if [ -z "${REPLACING_VERSIONS}" ] ; then
+ local msg=""
+ if [ -e "${D}"/boot/cmdline.txt -a -e "${ROOT}"/boot/cmdline.txt ] ; then
+ msg+="/boot/cmdline.txt "
+ fi
+ if [ -e "${D}"/boot/config.txt -a -e "${ROOT}"/boot/config.txt ] ; then
+ msg+="/boot/config.txt "
+ fi
+ if [ -n "${msg}" ] ; then
+ msg="This package installs following files: ${msg}."
+ msg="${msg} Please remove(backup) your copies during install"
+ msg="${msg} and merge settings afterwards."
+ msg="${msg} Further updates will be CONFIG_PROTECTed."
+ die "${msg}"
+ fi
+ fi
+
+ if ! grep "${ROOT}boot" /proc/mounts >/dev/null 2>&1; then
+ ewarn "${ROOT}boot is not mounted, the files might not be installed at the right place"
+ fi
+}
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ insinto /lib/modules
+ doins -r modules/*
+ insinto /boot
+ newins boot/kernel.img kernel-${PV}.img
+ newins boot/kernel7.img kernel7-${PV}.img
+
+ readme.gentoo_create_doc
+}
+
+DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"