summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-02-11 09:11:26 +0100
committerMichael Weber <xmw@gentoo.org>2016-02-11 09:11:42 +0100
commitbe1d0603891d4f83e0da9f3bf246c5bafbebd586 (patch)
treecae4642487d7f19b21490541a1b7255ca105f93e /sys-kernel/raspberrypi-sources
parentsci-chemistry/molden: Version Bump (diff)
downloadgentoo-be1d0603891d4f83e0da9f3bf246c5bafbebd586.tar.gz
gentoo-be1d0603891d4f83e0da9f3bf246c5bafbebd586.tar.bz2
gentoo-be1d0603891d4f83e0da9f3bf246c5bafbebd586.zip
sys-kernel/raspberrypi-sources: add lts rpi-4.4.y
Package-Manager: portage-2.2.27
Diffstat (limited to 'sys-kernel/raspberrypi-sources')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild
new file mode 100644
index 000000000000..9e7224829a8d
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-4.4.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-2 versionator
+EGIT_REPO_URI=https://github.com/raspberrypi/linux.git
+EGIT_PROJECT="raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(get_version_component_range 1-2).y"
+
+DESCRIPTION="Raspberry PI kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+KEYWORDS=""
+
+src_unpack() {
+ git-2_src_unpack
+ unpack_set_extraversion
+}