summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2016-11-10 16:16:36 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-11-12 16:47:05 +0100
commit0df7f10cdbac56b54e930940f35d79e3a9000b7e (patch)
tree258975c8b1754f408ed2b1d69a871f27174a06ad /sys-kernel/rt-sources/rt-sources-4.1.35_p41.ebuild
parentsci-misc/boinc: Add new icons to all ebuilds with revbump (diff)
downloadgentoo-0df7f10cdbac56b54e930940f35d79e3a9000b7e.tar.gz
gentoo-0df7f10cdbac56b54e930940f35d79e3a9000b7e.tar.bz2
gentoo-0df7f10cdbac56b54e930940f35d79e3a9000b7e.zip
sys-kernel/rt-sources: version bump to {3.18.44_p48,4.1.35_p41,4.4.30_p41} and remove old.
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/2800 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'sys-kernel/rt-sources/rt-sources-4.1.35_p41.ebuild')
-rw-r--r--sys-kernel/rt-sources/rt-sources-4.1.35_p41.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/rt-sources-4.1.35_p41.ebuild b/sys-kernel/rt-sources/rt-sources-4.1.35_p41.ebuild
new file mode 100644
index 000000000000..b33b2e437e03
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-4.1.35_p41.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit versionator
+
+CKV="$(get_version_component_range 1-3)"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst() {
+
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."