summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2017-06-10 19:05:57 +0200
committerAlice Ferrazzi <alicef@gentoo.org>2017-06-10 17:53:08 +0000
commit2e1084e0c553672dc83e5d589acd2be960f025ad (patch)
treef6c96ef145e61c5dd7abf18ea1a728134e85810d /sys-kernel/rt-sources/rt-sources-4.1.40_p48.ebuild
parentdev-python/backports-unittest-mock: remove old (diff)
downloadgentoo-2e1084e0c553672dc83e5d589acd2be960f025ad.tar.gz
gentoo-2e1084e0c553672dc83e5d589acd2be960f025ad.tar.bz2
gentoo-2e1084e0c553672dc83e5d589acd2be960f025ad.zip
sys-kernel/rt-sources: version bump to {3.18.55_p61,4.1.40_p48,4.4.70_p83,4.9.30_p21} and remove old
Package-Manager: Portage-2.3.6, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4905
Diffstat (limited to 'sys-kernel/rt-sources/rt-sources-4.1.40_p48.ebuild')
-rw-r--r--sys-kernel/rt-sources/rt-sources-4.1.40_p48.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/rt-sources-4.1.40_p48.ebuild b/sys-kernel/rt-sources/rt-sources-4.1.40_p48.ebuild
new file mode 100644
index 000000000000..ae57754ef482
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-4.1.40_p48.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit versionator
+
+CKV="$(get_version_component_range 1-3)"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst() {
+
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."