summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2017-07-08 16:05:20 +0200
committerAlice Ferrazzi <alicef@gentoo.org>2017-07-11 12:37:19 +0000
commitd2c1b561d29efaf5dbdcfdafd2813b65b4d4c524 (patch)
treea3c50d3a9da8cd83acada77f6f4d30736d2aef68 /sys-kernel/rt-sources/rt-sources-4.4.75_p88.ebuild
parentdev-util/checkbashisms: Removed old. (diff)
downloadgentoo-d2c1b561d29efaf5dbdcfdafd2813b65b4d4c524.tar.gz
gentoo-d2c1b561d29efaf5dbdcfdafd2813b65b4d4c524.tar.bz2
gentoo-d2c1b561d29efaf5dbdcfdafd2813b65b4d4c524.zip
sys-kernel/rt-sources: version bumps, eapi 6 and fix bug 624110
Gentoo-Bug: 624110 Package-Manager: Portage-2.3.6, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/5072
Diffstat (limited to 'sys-kernel/rt-sources/rt-sources-4.4.75_p88.ebuild')
-rw-r--r--sys-kernel/rt-sources/rt-sources-4.4.75_p88.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/rt-sources-4.4.75_p88.ebuild b/sys-kernel/rt-sources/rt-sources-4.4.75_p88.ebuild
new file mode 100644
index 000000000000..911287c4d4c2
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-4.4.75_p88.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit versionator
+
+CKV="$(get_version_component_range 1-3)"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."