summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2020-06-20 10:30:28 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-06-20 13:14:46 +0200
commit81b8d812b0cd2b51ac2a8407ac3dea3cad52cdf4 (patch)
tree58b8bea7678a3cc6affa894c1bac090ede7cad1e /sys-kernel/rt-sources
parentsys-kernel/rt-sources: Add rt-sources v5.4.44-rt27 (diff)
downloadgentoo-81b8d812b0cd2b51ac2a8407ac3dea3cad52cdf4.tar.gz
gentoo-81b8d812b0cd2b51ac2a8407ac3dea3cad52cdf4.tar.bz2
gentoo-81b8d812b0cd2b51ac2a8407ac3dea3cad52cdf4.zip
sys-kernel/rt-sources: Add rt-sources v5.6.17-rt10
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Closes: https://github.com/gentoo/gentoo/pull/16340 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-kernel/rt-sources')
-rw-r--r--sys-kernel/rt-sources/Manifest2
-rw-r--r--sys-kernel/rt-sources/rt-sources-5.6.17_p10.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-kernel/rt-sources/Manifest b/sys-kernel/rt-sources/Manifest
index 29f7170cee66..5482bb28206f 100644
--- a/sys-kernel/rt-sources/Manifest
+++ b/sys-kernel/rt-sources/Manifest
@@ -38,3 +38,5 @@ DIST patch-5.4.44-rt27.patch.xz 182448 BLAKE2B 8fa6baba31b76bda72d8f00e6cbff24a1
DIST patch-5.4.44.xz 1412464 BLAKE2B c7c0c189030402303992b130596f716c0afa7305a45996112971000d0de4d7945c9e988e0e7503d69cd4aff2ac3c003d330839ab1f3ed0a53fc7fa68c2e3da44 SHA512 1179f0c61d99ab136cc81bfed153e18a88cf4438f6be524b54d5f4ea76030e059c65e52d532cafe4eb7b1671c04583f6bf8f9114a3da969cd102a78a3530fd3f
DIST patch-5.6.14-rt7.patch.xz 158640 BLAKE2B 81e0a0c4b4feea3abd60efe89c7ae4be7dd8ba45999f514f63a9a6179c2c31acaf15911b0815c6f87aa7e3c36836fbb3cc065405c8be31134f3b2b144be48d72 SHA512 4d3604fa482bf6ae4d06ae97e85d10fd9248d174927713a2f010698137638a2d070ecf3e71cdea6529c67aad3fbfee8532adc2f3d810a4a7d6819e9ea19ae7af
DIST patch-5.6.14.xz 376464 BLAKE2B 01b64288759faa67aedfded7dfca5d8d1e894a863bf7bcaf91dd8f23c8b8c9df51d2e54ac5e414a33fc3469b32c10f1d630cf2636206b8e159d602df40ad3048 SHA512 8019bf12993f43d5508845a48b250d30220a8db6db262c8b97cd3f7c73abf0d054fcdfacb671644de529ceb495b95982d693a889051fb60fafc3180bd5b4f29e
+DIST patch-5.6.17-rt10.patch.xz 169292 BLAKE2B 3d4f591247d924d2cf89adc04846dc7cf8d9f58938fe7716560f97bfcc3e9c4c82f06cf1eacb8c95ef65d6f5ef624f969f849f9f3367beb9b95fb13eea3fd50b SHA512 5d5c7ff8da7a06aba70de38a03cfd25a4f3913c79d6723fd44a88fd7a5e9478a925587fda278b8552d14868c1c9c460105eb96fd2d80c3ce2043309e9cdedbad
+DIST patch-5.6.17.xz 466208 BLAKE2B 53d4753419b6500625da870212a164f535f5b41135005f87fb0c335430dbd6512a24fff3ff6071167893bed7a46c74a101031c26612821f4b9bf317eccec2fb9 SHA512 be922570e079a5bab8d23b504050afccca9e94b149e1460c49b78054735afe2469b5b49d056120eee5d774fff90059772ac105f7fa476d052d9cb18f81688846
diff --git a/sys-kernel/rt-sources/rt-sources-5.6.17_p10.ebuild b/sys-kernel/rt-sources/rt-sources-5.6.17_p10.ebuild
new file mode 100644
index 000000000000..12c5881dd444
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-5.6.17_p10.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64 ~arm64"
+
+HOMEPAGE="https://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit eapi7-ver
+
+CKV="$(ver_cut 1-3)"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="https://www.kernel.org/pub/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE} \
+ https://www.kernel.org/pub/linux/kernel/projects/rt/${K_BRANCH_ID}/older/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+src_prepare() {
+ default
+
+ # 627796
+ sed \
+ "s/default PREEMPT_NONE/default PREEMPT_RT/g" \
+ -i "${S}/kernel/Kconfig.preempt" || die "sed failed"
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."