summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2016-03-16 13:25:10 +0100
committerIan Delaney <idella4@gentoo.org>2016-03-16 21:24:59 +0800
commite86db144dad66d5eab9d6400244359df84501425 (patch)
treecd55385571b5aa4394af3e7329fe7ff00a02a0c6 /sys-kernel/tuxonice-sources/tuxonice-sources-4.1.19.ebuild
parentgames-roguelike/angband: ppc stable wrt bug #577022 (diff)
downloadgentoo-e86db144dad66d5eab9d6400244359df84501425.tar.gz
gentoo-e86db144dad66d5eab9d6400244359df84501425.tar.bz2
gentoo-e86db144dad66d5eab9d6400244359df84501425.zip
sys-kernel/tuxonice-sources: Version bumps.
Diffstat (limited to 'sys-kernel/tuxonice-sources/tuxonice-sources-4.1.19.ebuild')
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-4.1.19.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-4.1.19.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-4.1.19.ebuild
new file mode 100644
index 000000000000..85175dff9df7
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-4.1.19.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="24"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches/ http://tuxonice.nigelcunningham.com.au/ https://github.com/NigelCunningham/tuxonice-kernel"
+
+TUXONICE_PV="4.1.16"
+TUXONICE_DATE="2016-01-24"
+
+TUXONICE_PATCH="tuxonice-for-linux-${TUXONICE_PV}-${TUXONICE_DATE}.patch.bz2"
+TUXONICE_URI="http://tuxonice.nigelcunningham.com.au/downloads/all/${TUXONICE_PATCH}"
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_PATCH}"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="experimental"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any queries to the tuxonice-users mailing list:
+http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"