summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-25 22:14:42 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-25 23:49:23 +0100
commit2f05dc34863e8e4c5b82e357b4de744e671f42d5 (patch)
treefa2473ad3fe27ae8495551387e42c8a70f8b6ff8 /sys-kernel/vanilla-kernel
parentnet-p2p/cpuminer-opt: 3.10.6 version bump (diff)
downloadgentoo-2f05dc34863e8e4c5b82e357b4de744e671f42d5.tar.gz
gentoo-2f05dc34863e8e4c5b82e357b4de744e671f42d5.tar.bz2
gentoo-2f05dc34863e8e4c5b82e357b4de744e671f42d5.zip
sys-kernel/vanilla-kernel: Enable x86 (32-bit) support
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel/vanilla-kernel')
-rw-r--r--sys-kernel/vanilla-kernel/Manifest3
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-5.4.6-r1.ebuild31
2 files changed, 27 insertions, 7 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index 7d8a084f2de3..64ab1f46f8c6 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -1,2 +1,3 @@
-DIST linux-5.4.4.arch1-1.config 241587 BLAKE2B 71db76bf30a8d7f4dc680399b9f9fbb4236d1938bb86e23eb1ab236a667a959fc1cff788f7e432c43a6173e1bac4e20f3a6c3391d84275d46f1f66bd338bf538 SHA512 34d66658963dbd72fa3e96f2c5d5bccafb781fa14f6ebafe7859953929ba2fbb112f1435ca68cec8389d789cf0efa81d5fc0f5ac6dfa23a704348ab83709e9db
+DIST linux-5.4.3-arch1.i686.config 241295 BLAKE2B 795b6286bd1e7dc6aa5c1428e7bf08c204ce6c8cbee57863e9f64f8990790cc4398a7d062b54c89b1b80640f02a40fce028d9397725db0f968e8028b0611a20f SHA512 8c7387ded21c02b9cffee0e6d61a7040c44deae21764f743f7719f0d1c7adf684f6b62a501fe31709787ba741859e55fc3b8a3d3d27e52c09f2d8604212bf0a7
+DIST linux-5.4.4.arch1-1.amd64.config 241587 BLAKE2B 71db76bf30a8d7f4dc680399b9f9fbb4236d1938bb86e23eb1ab236a667a959fc1cff788f7e432c43a6173e1bac4e20f3a6c3391d84275d46f1f66bd338bf538 SHA512 34d66658963dbd72fa3e96f2c5d5bccafb781fa14f6ebafe7859953929ba2fbb112f1435ca68cec8389d789cf0efa81d5fc0f5ac6dfa23a704348ab83709e9db
DIST linux-5.4.6.tar.xz 109454640 BLAKE2B 8619492fedd4ae489a811561f72285b69deb827bb1db1f65be2a128d3bcbb69bdeec6b73650e1e8f72b18e5016c2df092bc77ee38be756d35f2903ecf0db1687 SHA512 9e1153e80303d6d5016856a25f3757259a3a428bad11208192315088d1f1a09957f5b8e966ab8cb5842ce1a740760f87474066294f8b410e9c44c810838bcdac
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.6-r1.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.6-r1.ebuild
index d7580d14ddb3..babbf9b9ea1e 100644
--- a/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.6-r1.ebuild
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-5.4.6-r1.ebuild
@@ -6,19 +6,27 @@ EAPI=7
inherit mount-boot savedconfig toolchain-funcs
MY_P=linux-${PV}
-CONFIG_VER=5.4.4.arch1-1
-CONFIG_HASH=f101331956bb37080dce191ca789a5c44fac9e69
+AMD64_CONFIG_VER=5.4.4.arch1-1
+AMD64_CONFIG_HASH=f101331956bb37080dce191ca789a5c44fac9e69
+I686_CONFIG_VER=5.4.3-arch1
+I686_CONFIG_HASH=076a52d43a08c4b3a3eacd1f2f9a855fb3b62f42
DESCRIPTION="Linux kernel built from vanilla upstream sources"
HOMEPAGE="https://www.kernel.org/"
SRC_URI="https://cdn.kernel.org/pub/linux/kernel/v5.x/${MY_P}.tar.xz
- https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux&id=${CONFIG_HASH}
- -> linux-${CONFIG_VER}.config"
+ amd64? (
+ https://git.archlinux.org/svntogit/packages.git/plain/trunk/config?h=packages/linux&id=${AMD64_CONFIG_HASH}
+ -> linux-${AMD64_CONFIG_VER}.amd64.config
+ )
+ x86? (
+ https://git.archlinux32.org/packages/plain/core/linux/config.i686?id=${I686_CONFIG_HASH}
+ -> linux-${I686_CONFIG_VER}.i686.config
+ )"
S=${WORKDIR}/${MY_P}
LICENSE="GPL-2"
SLOT="${PV}"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE="+initramfs"
# install-DEPEND actually
@@ -69,7 +77,18 @@ src_configure() {
ARCH=x86
)
- cp "${DISTDIR}"/linux-${CONFIG_VER}.config .config || die
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}"/linux-${AMD64_CONFIG_VER}.amd64.config .config || die
+ ;;
+ x86)
+ cp "${DISTDIR}"/linux-${I686_CONFIG_VER}.i686.config .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
# while Arch config is cool, we don't want gcc plugins as they
# break distcc
sed -i -e '/GCC_PLUGIN/d' .config || die