summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-01-15 06:58:30 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-01-15 07:17:51 +0200
commit22cfad75223eac7f46c48a2e7d21c278996ac477 (patch)
tree2e594565c1500488bcb3bb1966b3df5e2395268b /sys-kernel
parentapp-vim/nerdcommenter: remove old (diff)
downloadgentoo-22cfad75223eac7f46c48a2e7d21c278996ac477.tar.gz
gentoo-22cfad75223eac7f46c48a2e7d21c278996ac477.tar.bz2
gentoo-22cfad75223eac7f46c48a2e7d21c278996ac477.zip
sys-kernel/pf-sources: bump to 5.4-pf5
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.4_p5.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index f4b784d6b915..357670a2b2d9 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -17,3 +17,4 @@ DIST pf-sources-5.4_p1.patch 258131 BLAKE2B 23305be06df369a9bd7efdc1ab1c79bcbe6c
DIST pf-sources-5.4_p2.patch 444667 BLAKE2B 970e27405a2bcfd206b7c4d2852c1329b9197cd14c4ad1bdcde0d5a36af41efe26ffec26469150da224c55cae7bc31c726a2ce0c93f723527423c5346d477367 SHA512 3f8ec934c71d9541a621bdff7c6db247e91027e83e0c0afcb08a6f7a0e4bf9c7667e4ad4a2bc7dd1aa7bb95f23ebe4d1ba818fd8ee24bb6cbf4e8e80a9ce150c
DIST pf-sources-5.4_p3.patch 977402 BLAKE2B 718d3239745b6be9736d4d5f49daddaeb4c0d8e6cb64f7824f84cfa64f3d9f15f86571fccf60009c0cc478be545d1da472fc1189ebf8df4518bbc57bea906c77 SHA512 5f8cff5193f0baadff310a47fc9be9abfa710f68595c2fd543bb6c72d9524e335ecc26d28a41e0e5735db1702d3978e0501984dc0e1637e3a3b54ac5fb1b5026
DIST pf-sources-5.4_p4.patch 1683670 BLAKE2B df903d196334f502ed8056de684f51d8aa8f9f81ceb2cb5f17e1267fab2c77e0534bba55b895d266f1f940d211504511dd3afe0da1f30479ff7555be03ebcdca SHA512 e1d24d45d8b0c00c9a2cf20774e6adb251dcbdda15f535c30abcb1296985781ea9fd4d7e6867dbdc9c0fe6fbbc7634d1997020a3c2345339ac08ad2e1c92409f
+DIST pf-sources-5.4_p5.patch 2125349 BLAKE2B 52dfd6a76f9473937dc2fc0c138d424d7dbb781b08dd1c775cf6e9b2119381be4c71b6c6b00333cce47209de7d0e08a6872c33412acec670daee4944313504a7 SHA512 9c90b33b75453dcc2f0463225a19bef8475b71c6d3d99e8bb3d147ada0eaad29a3bee0038099aa45a6bd71496015b29a2cd00b9ab3c68fbc3bd6ee54155d3004
diff --git a/sys-kernel/pf-sources/pf-sources-5.4_p5.ebuild b/sys-kernel/pf-sources/pf-sources-5.4_p5.ebuild
new file mode 100644
index 000000000000..f95b603d66f4
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.4_p5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+ETYPE="sources"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+
+IUSE=""
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# No reason to bump this number unless something new gets included in genpatches,
+# in that case we can manually remove the linux kernel patches from genpatches.
+K_GENPATCHES_VER="1"
+
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security crew
+K_SECURITY_UNSUPPORTED="1"
+
+K_USEPV="yes"
+
+# We want the very basic patches from gentoo-sources, experimental patch
+# is already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+UNIPATCH_STRICTORDER="yes"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+
+PF_URI="https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch"
+SRC_URI="
+ ${KERNEL_URI}
+ ${PF_URI}
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz
+"
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+PATCHES=(
+ "${DISTDIR}/${P}.patch"
+)
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}