summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-07-03 19:28:57 -0400
committerMike Pagano <mpagano@gentoo.org>2022-07-03 19:28:57 -0400
commit238dfed6a759fa3f65c054de5c62c347a85eba42 (patch)
tree47b5dfabbf805d03c784f8d981353361ac79bcdc /sys-kernel
parentdev-libs/boost: Stabilize 1.79.0 hppa, #853676 (diff)
downloadgentoo-238dfed6a759fa3f65c054de5c62c347a85eba42.tar.gz
gentoo-238dfed6a759fa3f65c054de5c62c347a85eba42.tar.bz2
gentoo-238dfed6a759fa3f65c054de5c62c347a85eba42.zip
sys-kernel/git-sources: add 5.19_rc5
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.19_rc5.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 96c39784145e..a7afe55c2cb6 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -3,3 +3,4 @@ DIST patch-5.19-rc1.patch 90995640 BLAKE2B 0042e0a588fb4fa43259373e7c251e0f17f76
DIST patch-5.19-rc2.patch 91368249 BLAKE2B bef883f4eb087216758ed81dd83652f24486dbf918a7bdb3da2104eaaeda5cfbfa66b820c6085971b68b20daca9f0da2bca475420273ba765264dbed19b8e505 SHA512 8f59b859f7f464bc44dfb65f0d7dae435e01c5a6f2692243ba61249bd96e8b8fa5fa196461d0ad78ae90879d1aa9d89452ab93d1c86fe823a7a2f479b280340d
DIST patch-5.19-rc3.patch 91707998 BLAKE2B 838fb540ad60b1e6f90e90d873d470ae6defe5762239ab0113b7c552f425ecbf2701846ca8788414b198dd9df541f4387c62fed8e111fa3d73f063b98b26a536 SHA512 18a9a9c3254417425a6a9a4f438322ea926f2667621102fd715f0557dbbdf282a73af0c786ecce7fdc0fcd58f33443f470594f6b6cfd52c983bbf9c35d1d55b2
DIST patch-5.19-rc4.patch 92086340 BLAKE2B fec8a8ca4dc1f25f6f06c1b7b2031b9e5f40b4b6ef56effb9a6150ba88beda69ebe3a88cb5bd00ba8548490d3b98b573482a6cf5dc5ec2b8b006d61b67317279 SHA512 9a4f7b207d31e2a2299c47de8f3fbb01558512ebe899af132eb6b711a3dc92d57568b9479b559b4e1d1a7eb59c5731afe38673eb13d09b250ee8a3df2d7e4d4c
+DIST patch-5.19-rc5.patch 92286884 BLAKE2B 869cd7384fe6d7cb2752f7144b1fc8a030d1721e2502c0e4c20888b117d22c6411ea568852aa9e58459477f3bcea0b40762ec2bc37e1cf6e4467ef192223f4ed SHA512 237f3be30596050bf0654356511a77453e661e2724b67de9f3ba91db5260e30b5685cedc796f6ab39d5c28faf40c25ebf168f8153c95c9ee71e17af4a20378cf
diff --git a/sys-kernel/git-sources/git-sources-5.19_rc5.ebuild b/sys-kernel/git-sources/git-sources-5.19_rc5.ebuild
new file mode 100644
index 000000000000..64a9dd30df4c
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.19_rc5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.18"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}