summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Ferrazzi <alicef@gentoo.org>2019-06-02 18:44:52 +0000
committerAlice Ferrazzi <alicef@gentoo.org>2019-06-02 18:45:43 +0000
commit2a3a57780d75651c95f1ccab154ae42db1598767 (patch)
tree91b313b3f8051f8fa666740ca1528377910f9974 /sys-kernel
parentgui-apps/swayidle: 1.3 stable amd64 arm64 and x86 (diff)
downloadgentoo-2a3a57780d75651c95f1ccab154ae42db1598767.tar.gz
gentoo-2a3a57780d75651c95f1ccab154ae42db1598767.tar.bz2
gentoo-2a3a57780d75651c95f1ccab154ae42db1598767.zip
sys-kernel/kpatch: bump 0.6.3
Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Alice Ferrazzi <alicef@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/kpatch/Manifest1
-rw-r--r--sys-kernel/kpatch/kpatch-0.6.3.ebuild84
-rw-r--r--sys-kernel/kpatch/metadata.xml6
3 files changed, 91 insertions, 0 deletions
diff --git a/sys-kernel/kpatch/Manifest b/sys-kernel/kpatch/Manifest
index c6d912899b9a..750a99bcfdaa 100644
--- a/sys-kernel/kpatch/Manifest
+++ b/sys-kernel/kpatch/Manifest
@@ -1,3 +1,4 @@
DIST kpatch-0.4.0.tar.gz 124433 BLAKE2B 6ea18c4d590426f9db95e16d555307e264d1b7db362d421f72eaaf897703f7883c44cc49bd98b48d8789453962259d0b0e301aca325c94be6c21061d0621a9cf SHA512 0bbb49a06d02e9eb026be458eb904cf50f50461a67f16835a306bb3a4a57ef88b86ecf6bca6dfc91b921ba87b4c8b9d532e2a77e987e7c71583b8cb53520a1d7
DIST kpatch-0.6.0.tar.gz 153337 BLAKE2B 5c132b885f9f8bc3c7b514997a0b8b77280d0387431dd3eb73f45da4678b281961a03452b0ec590b37fc9568192135528a9a42bd5005530bd8b9175fe652f7b1 SHA512 7ac27639773a851ad6689743100ff973b4e3a30efc386bdf413c8f6167068d93c2d18820d87e1f1e96405fa3545dcb80a72db0011f07218a692f91f1f3c3655a
DIST kpatch-0.6.2.tar.gz 148110 BLAKE2B 9903c9423ee6268a0d87c55336e418a964474a3d7f35dd1ad613be7645a932cd09991652cd4a3af0b08a686f39e7c6c7f4b12d80c20c7ecd663aa703821503f8 SHA512 65098195330a2dbea4f8648c87c41f3a7751ffcb83b4e4c5f0a1146f91a8ae8c305d8f111a69304b31f1f12dd26da788af31a5477899bda098b7391cd0a32eca
+DIST kpatch-0.6.3.tar.gz 153100 BLAKE2B e95d1880ffc9ff6038bba98902d0f1e97c9f7f8d0f90eedc281c4bf0570217668cf7b701d038d6f06e9885ebdbb4407cc554d5175cf17eb8fd5051381f75deb3 SHA512 0d266dd837ad651d7f46047cf2c8de527d08274a885a154c53354f4b3c5679d91c766d7d42294ffe71cc548e5ee865c7555f24001882b806f2fb48825f9b0c06
diff --git a/sys-kernel/kpatch/kpatch-0.6.3.ebuild b/sys-kernel/kpatch/kpatch-0.6.3.ebuild
new file mode 100644
index 000000000000..763ccbeac5d3
--- /dev/null
+++ b/sys-kernel/kpatch/kpatch-0.6.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic linux-mod
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dynup/${PN}.git"
+else
+ SRC_URI="https://github.com/dynup/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Dynamic kernel patching for Linux"
+HOMEPAGE="https://github.com/dynup/kpatch"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+kpatch-build +kpatch kmod doc contrib test"
+
+RDEPEND="
+ app-crypt/pesign
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ sys-apps/pciutils
+"
+
+DEPEND="
+ ${RDEPEND}
+ dev-libs/elfutils
+ sys-devel/bison
+ test? ( dev-util/shellcheck-bin )
+"
+
+pkg_setup() {
+ if use kmod; then
+ if kernel_is gt 3 9 0; then
+ if ! linux_config_exists; then
+ eerror "Unable to check the currently running kernel for kpatch support"
+ eerror "Please be sure a .config file is available in the kernel src dir"
+ eerror "and ensure the kernel has been built."
+ else
+ # Fail to build if these kernel options are not enabled (see kpatch/kmod/core/Makefile)
+ CONFIG_CHECK="FUNCTION_TRACER HAVE_FENTRY MODULES SYSFS KALLSYMS_ALL"
+ ERROR_FUNCTION_TRACER="CONFIG_FUNCTION_TRACER must be enabled in the kernel's config file"
+ ERROR_HAVE_FENTRY="CONFIG_HAVE_FENTRY must be enabled in the kernel's config file"
+ ERROR_MODULES="CONFIG_MODULES must be enabled in the kernel's config file"
+ ERROR_SYSFS="CONFIG_SYSFS must be enabled in the kernel's config file"
+ ERROR_KALLSYMS_ALL="CONFIG_KALLSYMS_ALL must be enabled in the kernel's config file"
+ fi
+ else
+ eerror
+ eerror "kpatch is not available for Linux kernels below 4.0.0"
+ eerror
+ die "Upgrade the kernel sources before installing kpatch."
+ fi
+ check_extra_config
+ fi
+
+}
+
+src_prepare() {
+ replace-flags '-O?' '-O1'
+ default
+}
+
+src_compile() {
+ use kpatch-build && emake -C kpatch-build
+ use kpatch && emake -C kpatch
+ use kmod && set_arch_to_kernel && emake -C kmod
+ use doc && emake -C doc
+ use contrib && emake -C contrib
+ use test && emake check
+}
+
+src_install() {
+ use kpatch-build && emake DESTDIR="${D}" PREFIX="/usr" install -C kpatch-build
+ use kpatch && emake DESTDIR="${D}" PREFIX="/usr" install -C kpatch
+ use kmod && set_arch_to_kernel && emake DESTDIR="${D}" PREFIX="/usr" install -C kmod
+ use contrib && emake DESTDIR="${D}" PREFIX="/usr" install -C contrib
+ use doc && einstalldocs
+}
diff --git a/sys-kernel/kpatch/metadata.xml b/sys-kernel/kpatch/metadata.xml
index b393adbecca2..7e000f09b137 100644
--- a/sys-kernel/kpatch/metadata.xml
+++ b/sys-kernel/kpatch/metadata.xml
@@ -5,4 +5,10 @@
<email>alicef@gentoo.org</email>
</maintainer>
<longdescription lang="en">Dynamic kernel patching for the Linux kernel</longdescription>
+<use>
+ <flag name="kpatch-build">Enable tools which convert a source diff patch to a patch module.</flag>
+ <flag name="kpatch">Enable a command-line tool which allows a user to manage a collection of patch modules.</flag>
+ <flag name="kmod">Enable a kernel module (.ko file) which provides an interface for the patch modules to register new functions for replacement.</flag>
+ <flag name="contrib">Enable contrib kpatch services files.</flag>
+</use>
</pkgmetadata>