summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2016-06-27 09:24:55 +0200
committerAgostino Sarubbo <ago@gentoo.org>2016-06-27 09:24:55 +0200
commit3032967b9d9b769e07b2acdd6c125d98323af652 (patch)
treeb8c7dcf216579d84e5e168cb2966525580414c0e /sys-kernel
parentapp-arch/unadf: fix SRC_URI (diff)
downloadgentoo-3032967b9d9b769e07b2acdd6c125d98323af652.tar.gz
gentoo-3032967b9d9b769e07b2acdd6c125d98323af652.tar.bz2
gentoo-3032967b9d9b769e07b2acdd6c125d98323af652.zip
sys-kernel/git-sources: Automated version bump to 4.7_rc5
Package-Manager: portage-2.2.28 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-4.7_rc5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 5c5a98a5f8b8..e9a0c4fd1141 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -3,3 +3,4 @@ DIST patch-4.7-rc1.xz 5372116 SHA256 113a5441c67316e27b3c90d6ee07edd5e6df4e943dd
DIST patch-4.7-rc2.xz 5421916 SHA256 d323fd8f7ad015a1f929a3c2ebd99067475d64311b69fe66089a9b1600fba7b0 SHA512 c9853d063dba5978ad963e98c980205780ad4e3634af1478caaa7e2e1880c54d7cde8c70cce3350a44bb9f7171d7405d994eebe03a9526b4363d228d9b2073a7 WHIRLPOOL 730f616cecbfcab73747888788a4c108dc4925cac0026e6003a8589376a0d74a9445fa5bac92550053dfbe3dd7c8bd199060d58019306b9f8c0158e293e33e77
DIST patch-4.7-rc3.xz 5479492 SHA256 28302761d18747f9b81e61de6a30f7cde3f818b3b2620f60ca3fc4c7af749636 SHA512 1e4741494f8bb9c00a162b370b6f6d0e6690fdbf07bc0a50b4eb49fe3623a5f2af0a49fe1e28eadf5adce0e5aa583bba30f2e228c9d4ffd3d553b612f085c14b WHIRLPOOL 86a002578ed7b29320b917def28047ca3cf237024700b234db47c4065a7e3718a3d5960fefdc975c4ecddca13157192c92ff3054a61b60bcc7e5e4ce78cca1c0
DIST patch-4.7-rc4.xz 5524308 SHA256 fc7dd4593658bd667ac4088522b6c357d93ee667e2a04c87a72e0c026c5fe8b7 SHA512 bf4be16500078b567f35b2e6a23b1f4857a548904b17960acf91fc2ea62c3f5cd266e75f42f6fcbef5845ba8d06891a8ffdb30c4da92b18f6d85abf340d15051 WHIRLPOOL 4f031a34e5a4d4e252cd97ab6f038e1d111f6e5e0e5e6256e5d86792793bb8248bb8a77b7828969318ed092e9f321b66a651dc0f6a31cc4b64aa45127434e1bc
+DIST patch-4.7-rc5.xz 5556940 SHA256 331a73d6dfe217046ac8ac2669d3775113cbbdca8321c09d1a54223f3b9a0843 SHA512 614dde04eb5883bce1fa834e4a2a7533046dfc78313bd919d83eb35f32a3c27481776e629738db4923675f4ae07d312da0eb9095492f042d3050f02aa2930aa8 WHIRLPOOL 5b6517ca8e8976573d3c79e8a8ec4517eb21a9292d1c18c6b822410ebc850e592ea4546748a382155bceea0342a71ef33b40df55fb3628438cad5f4a2b0ff909
diff --git a/sys-kernel/git-sources/git-sources-4.7_rc5.ebuild b/sys-kernel/git-sources/git-sources-4.7_rc5.ebuild
new file mode 100644
index 000000000000..d666eac10267
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-4.7_rc5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="yes"
+K_BASE_VER="4.6"
+K_EXP_GENPATCHES_NOUSE="1"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.4"
+
+pkg_postinst() {
+ postinst_sources
+}