summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-09-25 18:02:55 -0400
committerMike Pagano <mpagano@gentoo.org>2022-09-25 18:02:55 -0400
commit5d54fa6f369cb8f9cc8cd7bd01dfd7fd504f458d (patch)
tree56aaccfc0dec8063aa3b804840a336879da41d26 /sys-kernel
parentdev-python/ansible-compat: disable py3.11 on 2.2.0 (diff)
downloadgentoo-5d54fa6f369cb8f9cc8cd7bd01dfd7fd504f458d.tar.gz
gentoo-5d54fa6f369cb8f9cc8cd7bd01dfd7fd504f458d.tar.bz2
gentoo-5d54fa6f369cb8f9cc8cd7bd01dfd7fd504f458d.zip
sys-kernel/git-sources: add 6.0_rc7
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-6.0_rc7.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index b175d1ec9f69..8d2e445730b1 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-6.0-rc3.patch 107861796 BLAKE2B 201851c3bb54d6af7a481b0b88067d738e0bb
DIST patch-6.0-rc4.patch 108161851 BLAKE2B 095c03da992f3b2ea26aaea3a10fa4efded546bb409e7580f689cd312dce77378397525776b9b138c158dbf59cd3061db99f48919afb003f3766965050b381ce SHA512 1386f9ac2fdfc5fbf07e524ed573be4f0df00fd2c0add97289e3d98ce36441339f81bfd3106dabf79898de50b363eff2f7cc88d03746f578b299fa13a0000438
DIST patch-6.0-rc5.patch 108427807 BLAKE2B 44f625c28f292d3ba2c43ebc6e06059c3874f0a4a1a645bd4ebda483fcc52eb4fc5dc166bd5bfc4dce5cac809901d53c9235bb7fc8003db73bbe2307b41057c0 SHA512 f5e8a8c74738b996633748eb8c84eaca3a1635335de4528a6f5c5446107c96b55e3b89867bd05207818e67fa711ed841dbd459b2b76d24f783f4b160404977a4
DIST patch-6.0-rc6.patch 108533829 BLAKE2B 279b3deaf52c40c2e0325092fd5a88c7e10fd5a4e61fbaa562ab66f6a906adca45629093fe102ae4edaa4276d2d471c0ea74f80c45f888b91989d3020122a82f SHA512 29f1b5cab76f41336416f462766c39655b1ba262293745273ed65df50848063cbc41386bb355165a84e4ddb1bbeaf559b818b6170521c5d16094deab008c9527
+DIST patch-6.0-rc7.patch 108721301 BLAKE2B d0765a518f737212ec29ddb675ed583eedd94677d82a0d53831ae19e060d7aef1e973f975b026bec3de8557f0c6c8a7a5403dbdddafd6103927d51ccba50e8f8 SHA512 c62ec2e6e385b62e9667c9c2b947a3090801a2b0bdd8f06374fdafa7e5f47f5c8bae5516abe8cedc9d78ef619033000c0d1c07fe65a533ac19f02dbab9f61511
diff --git a/sys-kernel/git-sources/git-sources-6.0_rc7.ebuild b/sys-kernel/git-sources/git-sources-6.0_rc7.ebuild
new file mode 100644
index 000000000000..6789923d7615
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-6.0_rc7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.19"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+K_NODRYRUN="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}