summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-03 15:24:16 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-03 15:26:45 +0200
commit7a8f2ec34bc4c2600bd7802d816c60b41a557582 (patch)
tree502c7eb17526d795641b64bf9e1c76778d06e470 /sys-kernel
parentdev-libs/liblouis: arm64 keyworded (diff)
downloadgentoo-7a8f2ec34bc4c2600bd7802d816c60b41a557582.tar.gz
gentoo-7a8f2ec34bc4c2600bd7802d816c60b41a557582.tar.bz2
gentoo-7a8f2ec34bc4c2600bd7802d816c60b41a557582.zip
sys-kernel/linux-firmware: Fix exclusion of amd-uc.img from savedconfig file
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-20190726-r1.ebuild (renamed from sys-kernel/linux-firmware/linux-firmware-20190726.ebuild)4
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-99999999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-kernel/linux-firmware/linux-firmware-20190726.ebuild b/sys-kernel/linux-firmware/linux-firmware-20190726-r1.ebuild
index 9baa48016e3d..528214a68b0e 100644
--- a/sys-kernel/linux-firmware/linux-firmware-20190726.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-20190726-r1.ebuild
@@ -274,13 +274,13 @@ src_prepare() {
fi
echo "# Remove files that shall not be installed from this list." > ${PN}.conf
- find * ! -type d \( ! -name ${PN}.conf -o -name amd-uc.img \) >> ${PN}.conf
+ find * ! -type d ! \( -name ${PN}.conf -o -name amd-uc.img \) >> ${PN}.conf
if use savedconfig; then
restore_config ${PN}.conf
ebegin "Removing all files not listed in config"
- find ! -type d ! -name ${PN}.conf -printf "%P\n" \
+ find ! -type d ! \( -name ${PN}.conf -o -name amd-uc.img \) -printf "%P\n" \
| grep -Fvx -f <(grep -v '^#' ${PN}.conf \
|| die "grep failed, empty config file?") \
| xargs -d '\n' --no-run-if-empty rm
diff --git a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
index c2afff9ee0c0..bc18789f40bd 100644
--- a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
@@ -274,13 +274,13 @@ src_prepare() {
fi
echo "# Remove files that shall not be installed from this list." > ${PN}.conf
- find * ! -type d \( ! -name ${PN}.conf -o -name amd-uc.img \) >> ${PN}.conf
+ find * ! -type d ! \( -name ${PN}.conf -o -name amd-uc.img \) >> ${PN}.conf
if use savedconfig; then
restore_config ${PN}.conf
ebegin "Removing all files not listed in config"
- find ! -type d ! -name ${PN}.conf -printf "%P\n" \
+ find ! -type d ! \( -name ${PN}.conf -o -name amd-uc.img \) -printf "%P\n" \
| grep -Fvx -f <(grep -v '^#' ${PN}.conf \
|| die "grep failed, empty config file?") \
| xargs -d '\n' --no-run-if-empty rm