summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2020-11-16 07:54:24 +0100
committerAgostino Sarubbo <ago@gentoo.org>2020-11-16 07:54:24 +0100
commit7cddf22157a1094b25b127bfe99f7172f7b2f335 (patch)
treeae3b54cbab06a25a72b0b4e4ab508036f945e9e4 /sys-kernel
parentsys-devel/llvmgold: Stabilize 11 ppc64, #754744 (diff)
downloadgentoo-7cddf22157a1094b25b127bfe99f7172f7b2f335.tar.gz
gentoo-7cddf22157a1094b25b127bfe99f7172f7b2f335.tar.bz2
gentoo-7cddf22157a1094b25b127bfe99f7172f7b2f335.zip
sys-kernel/git-sources: Automated version bump to 5.10_rc4.
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.10_rc4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index a2cec6b90212..07999e85f250 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -2,3 +2,4 @@ DIST linux-5.9.tar.xz 115507140 BLAKE2B e8d11472d63a9f8409ca12a2e8c97c6963a3d451
DIST patch-5.10-rc1.patch 63423359 BLAKE2B 83bd8492121f572584805667cda35964a1ab68730f7a61e2f6d5de950b61c29b08728596fd8802cfa02b58986da3559ffbb41be70816533bd6139fda55b9f233 SHA512 80f493f134cdce969f80ebf39dd473d1dce00b3fa419569ba761a4b91172fca2112892a91ca1d2f996e1a85e60840ec1244af0e735be46d285e941efa42b5bb1
DIST patch-5.10-rc2.patch 65041019 BLAKE2B 1bba1e257e24d6bf601cc8bc90143ec547a78218738af03d35edab9979d281a3071456c925c248c5f73d8e1d02ce07f5cf7255df5f957fe6a69fcf390149f8f7 SHA512 91b322b6cfc65b056332353b242cd2ce25148643cf96d19af5c37ec0a67a150c2d1757d1c665e7158a7e50f764b7645d553a7688d878a7fd7e5756f906dbc7ef
DIST patch-5.10-rc3.patch 65452543 BLAKE2B c93fc460613fc75b323580916376d6300faea9856f1873e193ffd552f375a7348e278a37e949bbe5ef2ce4ab26eea5fee6ada4cf610650caed1c974ec7d5c226 SHA512 7cab607fb72b524217f39f1aabd6f7f24a3c5ec08a68cc6346d574c8bebcaef46aaf51d91d13ba9117f55ac9efeb95aaff6b95e683f9a87262028cbc0910426d
+DIST patch-5.10-rc4.patch 65892587 BLAKE2B a9ba5ce6f0c9f2a8524bbf65515f8aa7ca023d532ba560fe512d17e9186396f4667dbf0318b1863934fcd47c2276e6f7c58fddc449522000878db4b60227a8b3 SHA512 45b58dc20d56951c1bcb750d2cb6d345552721168b1a40aa2046fc4ad22a9d9695f03fd13ff5c3e5138110986749860589e26507d7e87901916f942e8da0aacd
diff --git a/sys-kernel/git-sources/git-sources-5.10_rc4.ebuild b/sys-kernel/git-sources/git-sources-5.10_rc4.ebuild
new file mode 100644
index 000000000000..90316ad99864
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.10_rc4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.9"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}