summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-11-11 08:31:20 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-11-11 08:31:45 +0200
commit8393924f562005c913712f501c3dac202fb27022 (patch)
treed5a3f638bec969b88a3ffb44355ba2a01cf309e0 /sys-kernel
parentwww-client/chromium: arm64 stable, bug #753848 (diff)
downloadgentoo-8393924f562005c913712f501c3dac202fb27022.tar.gz
gentoo-8393924f562005c913712f501c3dac202fb27022.tar.bz2
gentoo-8393924f562005c913712f501c3dac202fb27022.zip
sys-kernel/pf-sources: bump to 5.9-pf4
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.9_p4.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index c88bcbfdad80..295b71816320 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -11,3 +11,4 @@ DIST pf-sources-5.7_p7.patch 2471776 BLAKE2B c87c9a5f159967877a2858da1af919332aa
DIST pf-sources-5.8_p7.patch 2546471 BLAKE2B 9eae65836ee0a4e67737462325753b6201c40fcf93f99a114e929f9557fb7bcf9ea619c2502f7824db6bdcf96c7a7640ad0cc1ff5dafa494a532e6f9ee4964b2 SHA512 0449f4ac292d8b0ac6222c273bc535acae5b1e8bdb9c6d196098d61de78fce6739911094bc8f710e4ef3ec187964ee8a146aa09c87f241e816ef5515272059eb
DIST pf-sources-5.9_p1.patch 35818 BLAKE2B c28c292b527c1116b927861dbcdfb948e1e7d30018ecacfa89425fb0b357f2a2cb93daa681ad6a940f936b255453770c743db2a95f8ad67bd6ab772febae7a76 SHA512 82f5583fdb8862a628265f188473fc2cfaaad1ffb06292248a69fc012058f743906aca7abcd88fa223e32f0a626748ae8111fa6858629182d0482989a0f7f725
DIST pf-sources-5.9_p2.patch 1222181 BLAKE2B 1a444ba68ade78f7862c474d52c021064ed78eefb68f03960ac9beb75edfc48f1da970cdaf06f78642d1d4d06fc266801228e184eafd211f3ae29811019ea8d2 SHA512 a2073d9a38fba54f32ec21fd4df928831649b80aa4786f2d58f7ce090d7f768abe2556e92c7af719c7bc8674bee5f940f2555bc5ba39b9528547e6ea5a819a36
+DIST pf-sources-5.9_p4.patch 1978557 BLAKE2B 1863fbf17732dad7e6f96b2ddfb66b424cc4cf9649eaff06b9e043e763a6d7a5941a80f3a1d2b6edc9987da41b3e9eb346c1fd63422f14f5cee285fb2de12f0e SHA512 d08011d285cfc1db431a92de9e58f5c3bde3e556cbca3237a7fd9ca234b9598c34b71482d0a9ac117e1fa15860c64aaa60c61435443c7cfa0548a620fe992b16
diff --git a/sys-kernel/pf-sources/pf-sources-5.9_p4.ebuild b/sys-kernel/pf-sources/pf-sources-5.9_p4.ebuild
new file mode 100644
index 000000000000..f2344adc15dc
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.9_p4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Define what default functions to run
+ETYPE="sources"
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# Just get basic genpatches, -pf patch set already includes vanilla-linux
+# updates
+K_GENPATCHES_VER="1"
+
+# -pf already sets EXTRAVERSION to kernel Makefile
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security team
+K_SECURITY_UNSUPPORTED="1"
+
+# We want the very basic patches from gentoo-sources, experimental patch is
+# already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+inherit kernel-2 optfeature
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/-/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+SRC_URI="${KERNEL_URI}
+ https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+S="${WORKDIR}/linux-${PVR}-pf"
+
+PATCHES=( "${DISTDIR}/${P}.patch" )
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+ see: ${HOMEPAGE}."
+
+pkg_setup() {
+ ewarn ""
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn ""
+
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ elog "Optional features:"
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}