summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-11-23 10:33:25 -0500
committerMike Gilbert <floppym@gentoo.org>2017-11-23 10:33:25 -0500
commit8e2b9da48f56ff91cef3f794f6c5787856dbad37 (patch)
tree84a836a109a632694bbaccce290e2c8ad99e45cd /sys-kernel
parentsys-kernel/linux-firmware: set QA_PREBUILT (diff)
downloadgentoo-8e2b9da48f56ff91cef3f794f6c5787856dbad37.tar.gz
gentoo-8e2b9da48f56ff91cef3f794f6c5787856dbad37.tar.bz2
gentoo-8e2b9da48f56ff91cef3f794f6c5787856dbad37.zip
sys-kernel/linux-firmware: convert live ebuild to EAPI 6 and git-r3
Package-Manager: Portage-2.3.15, Repoman-2.3.6_p7
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/linux-firmware/linux-firmware-99999999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
index 0b15091c69b4..1056574b8066 100644
--- a/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
+++ b/sys-kernel/linux-firmware/linux-firmware-99999999.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
inherit savedconfig
if [[ ${PV} == 99999999* ]]; then
- inherit git-2
+ inherit git-r3
SRC_URI=""
- EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
+ EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
KEYWORDS=""
else
- SRC_URI="mirror://gentoo/${P}.tar.xz"
+ GIT_COMMIT=""
+ SRC_URI="https://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git/snapshot/linux-firmware-${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
@@ -67,7 +68,7 @@ QA_PREBUILT="lib/firmware/*"
src_unpack() {
if [[ ${PV} == 99999999* ]]; then
- git-2_src_unpack
+ git-r3_src_unpack
else
default
# rename directory from git snapshot tarball
@@ -76,6 +77,7 @@ src_unpack() {
}
src_prepare() {
+ default
echo "# Remove files that shall not be installed from this list." > ${PN}.conf
find * \( \! -type d -and \! -name ${PN}.conf \) >> ${PN}.conf