summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-05 01:28:33 +0000
committerSam James <sam@gentoo.org>2021-12-05 01:28:33 +0000
commitc0ccdb6df2415c4ccc31c6535284f412a9ae9b2f (patch)
tree9cbef36a6edff2d078f58b6155c65324f8f8126e /sys-kernel
parentsys-kernel/raspberrypi-sources: add 5.10.63_p20211029 (diff)
downloadgentoo-c0ccdb6df2415c4ccc31c6535284f412a9ae9b2f.tar.gz
gentoo-c0ccdb6df2415c4ccc31c6535284f412a9ae9b2f.tar.bz2
gentoo-c0ccdb6df2415c4ccc31c6535284f412a9ae9b2f.zip
sys-kernel/raspberrypi-sources: add 5.10.9999
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.9999.ebuild b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.9999.ebuild
new file mode 100644
index 000000000000..d6ff24d0a8fa
--- /dev/null
+++ b/sys-kernel/raspberrypi-sources/raspberrypi-sources-5.10.9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ETYPE=sources
+K_DEFCONFIG="bcmrpi_defconfig"
+K_SECURITY_UNSUPPORTED=1
+EXTRAVERSION="-${PN}/-*"
+inherit kernel-2
+detect_version
+detect_arch
+
+inherit git-r3
+EGIT_REPO_URI="https://github.com/raspberrypi/linux.git -> raspberrypi-linux.git"
+EGIT_BRANCH="rpi-$(ver_cut 1-2).y"
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${PV}-raspberrypi"
+EGIT_CLONE_TYPE="shallow"
+
+DESCRIPTION="Raspberry Pi kernel sources"
+HOMEPAGE="https://github.com/raspberrypi/linux"
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack_set_extraversion
+}