summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-08 23:02:39 +0100
committerMichał Górny <mgorny@gentoo.org>2018-03-08 23:18:55 +0100
commitfe261b0f446e77a494ef1ec42b444cbef967c77e (patch)
tree5c53dfdca57215a4c5548018b7144ec66b610332 /sys-libs/compiler-rt
parentdev-util/lldb: Control lit job count (diff)
downloadgentoo-fe261b0f446e77a494ef1ec42b444cbef967c77e.tar.gz
gentoo-fe261b0f446e77a494ef1ec42b444cbef967c77e.tar.bz2
gentoo-fe261b0f446e77a494ef1ec42b444cbef967c77e.zip
sys-libs/compiler-rt: Control lit job count
Closes: https://bugs.gentoo.org/649554
Diffstat (limited to 'sys-libs/compiler-rt')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild5
-rw-r--r--sys-libs/compiler-rt/compiler-rt-9999.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild
index 712fe0ab6fd0..7a1bf830fe7d 100644
--- a/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-6.0.9999.ebuild
@@ -8,7 +8,8 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils flag-o-matic git-r3 llvm python-any-r1 toolchain-funcs
+inherit cmake-utils flag-o-matic git-r3 llvm multiprocessing \
+ python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
@@ -92,7 +93,7 @@ src_configure() {
if use test; then
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
-DCOMPILER_RT_TEST_COMPILER="${EPREFIX}/usr/lib/llvm/${LLVM_SLOT}/bin/clang"
-DCOMPILER_RT_TEST_CXX_COMPILER="${EPREFIX}/usr/lib/llvm/${LLVM_SLOT}/bin/clang++"
diff --git a/sys-libs/compiler-rt/compiler-rt-9999.ebuild b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
index 13a501b66836..d843a8f3e3eb 100644
--- a/sys-libs/compiler-rt/compiler-rt-9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-9999.ebuild
@@ -8,7 +8,8 @@ EAPI=6
CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
-inherit cmake-utils flag-o-matic git-r3 llvm python-any-r1 toolchain-funcs
+inherit cmake-utils flag-o-matic git-r3 llvm multiprocessing \
+ python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
@@ -91,7 +92,7 @@ src_configure() {
if use test; then
mycmakeargs+=(
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
- -DLLVM_LIT_ARGS="-vv"
+ -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
-DCOMPILER_RT_TEST_COMPILER="${EPREFIX}/usr/lib/llvm/${LLVM_SLOT}/bin/clang"
-DCOMPILER_RT_TEST_CXX_COMPILER="${EPREFIX}/usr/lib/llvm/${LLVM_SLOT}/bin/clang++"