summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-11-07 23:17:39 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-11-07 23:19:03 +0100
commita159ca3e2c2f6466507807024a3035fe2cd62e24 (patch)
tree9eeefdd71abd0fa6ec58378fdefb782c783317c7 /sys-libs/db/db-4.5.20_p2-r1.ebuild
parentmedia-gfx/slic3r: Add patch by Chris Mansfield for recent boost (diff)
downloadgentoo-a159ca3e2c2f6466507807024a3035fe2cd62e24.tar.gz
gentoo-a159ca3e2c2f6466507807024a3035fe2cd62e24.tar.bz2
gentoo-a159ca3e2c2f6466507807024a3035fe2cd62e24.zip
sys-libs/db: Next batch of EAPI-7 revbumps
Fixed some minor issues from previous EAPI-7 revbump. Closes: https://bugs.gentoo.org/697542 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-libs/db/db-4.5.20_p2-r1.ebuild')
-rw-r--r--sys-libs/db/db-4.5.20_p2-r1.ebuild177
1 files changed, 0 insertions, 177 deletions
diff --git a/sys-libs/db/db-4.5.20_p2-r1.ebuild b/sys-libs/db/db-4.5.20_p2-r1.ebuild
deleted file mode 100644
index 6509b9634399..000000000000
--- a/sys-libs/db/db-4.5.20_p2-r1.ebuild
+++ /dev/null
@@ -1,177 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit eutils db flag-o-matic java-pkg-opt-2 autotools multilib
-
-#Number of official patches
-#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
-PATCHNO=${PV/*.*.*_p}
-if [[ ${PATCHNO} == "${PV}" ]] ; then
- MY_PV=${PV}
- MY_P=${P}
- PATCHNO=0
-else
- MY_PV=${PV/_p${PATCHNO}}
- MY_P=${PN}-${MY_PV}
-fi
-
-S="${WORKDIR}/${MY_P}/build_unix"
-DESCRIPTION="Oracle Berkeley DB"
-HOMEPAGE="http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html"
-SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
-for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
- export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
-done
-
-LICENSE="Sleepycat"
-SLOT="4.5"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
-IUSE="tcl java doc cxx rpc"
-
-DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
- java? ( >=virtual/jdk-1.4 )
- >=sys-devel/binutils-2.16.1"
-RDEPEND="tcl? ( dev-lang/tcl )
- java? ( >=virtual/jre-1.4 )"
-
-src_unpack() {
- unpack "${MY_P}".tar.gz
- cd "${WORKDIR}"/"${MY_P}"
- for (( i=1 ; i<=${PATCHNO} ; i++ ))
- do
- epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
- done
- epatch "${FILESDIR}"/"${PN}"-"${SLOT}"-libtool.patch
-
- # use the includes from the prefix
- epatch "${FILESDIR}"/"${PN}"-4.3-jni-check-prefix-first.patch
- epatch "${FILESDIR}"/"${PN}"-4.3-listen-to-java-options.patch
-
- sed -e "/^DB_RELEASE_DATE=/s/%B %e, %Y/%Y-%m-%d/" -i dist/RELEASE
-
- # Include the SLOT for Java JAR files
- # This supersedes the unused jarlocation patches.
- sed -r -i \
- -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- "${S}"/../dist/Makefile.in
-
- # START of 4.5+earlier specific
- # Upstream sucks, they normally concat these
- cd "${S}"/../dist/aclocal
- for i in *; do ln -s $i ${i%.ac}.m4 ; done ;
- cd "${S}"/../dist/aclocal_java
- for i in *; do ln -s $i ${i%.ac}.m4 ; done ;
- # END of 4.5+earlier specific
- cd "${S}"/../dist
- rm -f aclocal/libtool.{m4,ac} aclocal.m4
- sed -i \
- -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
- configure.ac
- sed -i \
- -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
- aclocal/programs.m4
- AT_M4DIR="aclocal aclocal_java" eautoreconf
- # Upstream sucks - they do autoconf and THEN replace the version variables.
- . ./RELEASE
- sed -i \
- -e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \
- -e "s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" \
- -e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \
- -e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \
- -e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \
- -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" configure
-}
-
-src_compile() {
- # compilation with -O0 fails on amd64, see bug #171231
- if use amd64; then
- replace-flags -O0 -O2
- is-flagq -O[s123] || append-flags -O2
- fi
-
- local myconf=""
-
- use amd64 && myconf="${myconf} --with-mutex=x86/gcc-assembly"
-
- myconf="${myconf} $(use_enable cxx)"
-
- use tcl \
- && myconf="${myconf} --enable-tcl --with-tcl=${EPREFIX}/usr/$(get_libdir)" \
- || myconf="${myconf} --disable-tcl"
-
- myconf="${myconf} $(use_enable java)"
- if use java; then
- myconf="${myconf} --with-java-prefix=${JAVA_HOME}"
- # Can't get this working any other way, since it returns spaces, and
- # bash doesn't seem to want to pass correctly in any way i try
- local javaconf="-with-javac-flags=$(java-pkg_javac-args)"
- fi
-
- [[ -n ${CBUILD} ]] && myconf="${myconf} --build=${CBUILD}"
-
- # the entire testsuite needs the TCL functionality
- if use tcl && use test ; then
- myconf="${myconf} --enable-test"
- else
- myconf="${myconf} --disable-test"
- fi
-
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU; then
- append-ldflags -Wl,--default-symver
- fi
-
- cd "${S}" && ECONF_SOURCE="${S}"/../dist econf \
- --prefix="${EPREFIX}"/usr \
- --mandir="${EPREFIX}"/usr/share/man \
- --infodir="${EPREFIX}"/usr/share/info \
- --datadir="${EPREFIX}"/usr/share \
- --sysconfdir="${EPREFIX}"/etc \
- --localstatedir="${EPREFIX}"/var/lib \
- --libdir="${EPREFIX}"/usr/"$(get_libdir)" \
- --enable-compat185 \
- --enable-o_direct \
- --without-uniquename \
- $(use_enable rpc) \
- --host="${CHOST}" \
- ${myconf} "${javaconf}" || die "configure failed"
-
- sed -e "s,\(^STRIP *=\).*,\1\"true\"," Makefile > Makefile.cpy \
- && mv Makefile.cpy Makefile
-
- emake || die "make failed"
-}
-
-src_install() {
- einstall libdir="${ED}/usr/$(get_libdir)" STRIP="true" || die
-
- db_src_install_usrbinslot
-
- db_src_install_headerslot
-
- db_src_install_doc
-
- db_src_install_usrlibcleanup
-
- dodir /usr/sbin
- # This file is not always built, and no longer exists as of db-4.8
- [[ -f "${ED}"/usr/bin/berkeley_db_svc ]] && \
- mv "${ED}"/usr/bin/berkeley_db_svc "${ED}"/usr/sbin/berkeley_db"${SLOT/./}"_svc
-
- if use java; then
- java-pkg_regso "${ED}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${ED}"/usr/"$(get_libdir)"/*.jar
- rm -f "${ED}"/usr/"$(get_libdir)"/*.jar
- fi
-}
-
-pkg_postinst() {
- db_fix_so
-}
-
-pkg_postrm() {
- db_fix_so
-}