summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-02-07 23:01:12 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-02-07 23:02:38 +0000
commit3a821c3499a6f99b780eec2d5dd81c785535600c (patch)
treeaf89874e202b1ec184d8f3f88e7bcdd33e563aa3 /sys-libs/glibc/glibc-2.27-r6.ebuild
parenttoolchain-glibc.eclass: ignore USE=headers-only for native case, bug #677474 (diff)
downloadgentoo-3a821c3499a6f99b780eec2d5dd81c785535600c.tar.gz
gentoo-3a821c3499a6f99b780eec2d5dd81c785535600c.tar.bz2
gentoo-3a821c3499a6f99b780eec2d5dd81c785535600c.zip
sys-libs/glibc: ignore USE=headers-only for native case, bug #677474
Let's not allow users to "deinstall" native glibc. Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/677474 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-2.27-r6.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.27-r6.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.27-r6.ebuild b/sys-libs/glibc/glibc-2.27-r6.ebuild
index 7125f84f4dab..668e6795b243 100644
--- a/sys-libs/glibc/glibc-2.27-r6.ebuild
+++ b/sys-libs/glibc/glibc-2.27-r6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -459,7 +459,7 @@ setup_env() {
export ABI=${ABI:-${DEFAULT_ABI:-default}}
- if use headers-only ; then
+ if just_headers ; then
# Avoid mixing host's CC and target's CFLAGS_${ABI}:
# At this bootstrap stage we have only binutils for
# target but not compiler yet.