summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2019-04-21 21:05:35 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-04-21 21:06:05 +0200
commitfedcbfbed423e21c79c2088f3776e918473fd814 (patch)
treea33f3450f71164aa217747702a5944f3d36ae60e /sys-libs/glibc/glibc-9999.ebuild
parentsci-libs/opencascade: fix flag description (diff)
downloadgentoo-fedcbfbed423e21c79c2088f3776e918473fd814.tar.gz
gentoo-fedcbfbed423e21c79c2088f3776e918473fd814.tar.bz2
gentoo-fedcbfbed423e21c79c2088f3776e918473fd814.zip
sys-libs/glibc: Add small locale install hack for riscv
Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/glibc/glibc-9999.ebuild')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index b01dc8236359..4951020d5199 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1263,6 +1263,17 @@ glibc_do_src_install() {
fi
done
+ # HACK: If we're building for riscv, we need to additionally make sure that
+ # we can find the locale archive afterwards
+ case ${CTARGET} in
+ riscv*)
+ if [[ ! -e ${ED}/usr/lib/locale ]] ; then
+ dosym ../$(get_libdir)/locale /usr/lib/locale
+ fi
+ ;;
+ *) ;;
+ esac
+
cd "${S}"
# Install misc network config files