summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-03-27 16:05:35 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-03-27 16:06:10 +0200
commita25a710d9ccd4aa4f5a08cb035aab797913607c0 (patch)
treec0c8d3c3343e5d5431f3c96c5d41a2a4f2292399 /sys-libs/glibc
parentsys-process/at: keyword ~riscv (diff)
downloadgentoo-a25a710d9ccd4aa4f5a08cb035aab797913607c0.tar.gz
gentoo-a25a710d9ccd4aa4f5a08cb035aab797913607c0.tar.bz2
gentoo-a25a710d9ccd4aa4f5a08cb035aab797913607c0.zip
sys-libs/glibc: Build binaries are BROOT not SYSROOT
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.35.ebuild4
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-2.35.ebuild b/sys-libs/glibc/glibc-2.35.ebuild
index 0237132b9373..c02fa282882f 100644
--- a/sys-libs/glibc/glibc-2.35.ebuild
+++ b/sys-libs/glibc/glibc-2.35.ebuild
@@ -518,8 +518,8 @@ setup_env() {
# Last, we need the settings of the *build* environment, not of the
# target environment...
- local current_binutils_path=$(env ROOT="${SYSROOT}" binutils-config -B)
- local current_gcc_path=$(env ROOT="${SYSROOT}" gcc-config -B)
+ local current_binutils_path=$(env ROOT="${BROOT}" binutils-config -B)
+ local current_gcc_path=$(env ROOT="${BROOT}" gcc-config -B)
einfo "Overriding clang configuration, since it won't work here"
export CC="${current_gcc_path}/gcc"
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index f9c41f6d8ccc..9ba451c12e1a 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -518,8 +518,8 @@ setup_env() {
# Last, we need the settings of the *build* environment, not of the
# target environment...
- local current_binutils_path=$(env ROOT="${SYSROOT}" binutils-config -B)
- local current_gcc_path=$(env ROOT="${SYSROOT}" gcc-config -B)
+ local current_binutils_path=$(env ROOT="${BROOT}" binutils-config -B)
+ local current_gcc_path=$(env ROOT="${BROOT}" gcc-config -B)
einfo "Overriding clang configuration, since it won't work here"
export CC="${current_gcc_path}/gcc"