summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-20 18:16:19 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-01-20 18:16:19 +0100
commita9e179bf517964dd38d81503ee5393e195b1cb6a (patch)
treecd8f7b34da0258f3e8720d151dea30cea99910e4 /sys-libs/glibc
parentsys-libs/glibc: On second thought, let's not use linux-info.eclass here. (diff)
downloadgentoo-a9e179bf517964dd38d81503ee5393e195b1cb6a.tar.gz
gentoo-a9e179bf517964dd38d81503ee5393e195b1cb6a.tar.bz2
gentoo-a9e179bf517964dd38d81503ee5393e195b1cb6a.zip
sys-libs/glibc: rpcgen is not used here anymore, so no need for special treatmet at abi migration
Bug: https://bugs.gentoo.org/644700 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild6
1 files changed, 0 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index a215358c1b2c..522a3674fe0c 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -935,16 +935,10 @@ glibc_do_configure() {
# is built with MULTILIB_ABIS="amd64 x86" but we want to
# add x32 to it, gcc/glibc don't yet support x32.
#
- # This reqires net-libs/rpcsvc-proto now (which provides
- # rpcgen) !!! Needs analysis how to best add to deps.
- #
if [[ -n ${GCC_BOOTSTRAP_VER} ]] && use multilib ; then
echo 'main(){}' > "${T}"/test.c
if ! $(tc-getCC ${CTARGET}) ${CFLAGS} ${LDFLAGS} "${T}"/test.c -Wl,-emain -lgcc 2>/dev/null ; then
sed -i -e '/^CC = /s:$: -B$(objdir)/../'"gcc-${GCC_BOOTSTRAP_VER}/${ABI}:" config.make || die
- mkdir -p sunrpc
- cp $(which rpcgen) sunrpc/cross-rpcgen || die
- touch -t 202001010101 sunrpc/cross-rpcgen || die
fi
fi
}