summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-11 21:52:29 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-11 21:52:29 +0100
commitc9f6a29817f5039507af213da5abb0254b13da19 (patch)
tree58a78cda1876dc1be382f5a00ea2543352836aca /sys-libs/glibc
parentdev-ruby/capybara: move ~sparc forward (diff)
downloadgentoo-c9f6a29817f5039507af213da5abb0254b13da19.tar.gz
gentoo-c9f6a29817f5039507af213da5abb0254b13da19.tar.bz2
gentoo-c9f6a29817f5039507af213da5abb0254b13da19.zip
sys-libs/glibc: drop devpts mount checks, bug #704780
This is the same as b793253be2f42 ("sys-libs/glibc: drop devpts mount checks, bug #704780") applied to stable ebuilds. Toralf reports that sys-apps/bubblewrap also does not follow tty group convention when mounts devpts. Let's drop it from stable ebuilds as well. Reported-by: Toralf Förster Reported-by: Kai Krakow Closes: https://bugs.gentoo.org/704780 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.30-r8.ebuild24
1 files changed, 0 insertions, 24 deletions
diff --git a/sys-libs/glibc/glibc-2.30-r8.ebuild b/sys-libs/glibc/glibc-2.30-r8.ebuild
index 14ca4e95a445..aea0098e69f7 100644
--- a/sys-libs/glibc/glibc-2.30-r8.ebuild
+++ b/sys-libs/glibc/glibc-2.30-r8.ebuild
@@ -516,27 +516,6 @@ glibc_banner() {
echo "${b}"
}
-check_devpts() {
- # Make sure devpts is mounted correctly for use w/out setuid pt_chown.
-
- # If merely building the binary package, then there's nothing to verify.
- [[ ${MERGE_TYPE} == "buildonly" ]] && return
-
- # Only sanity check when installing the native glibc.
- [[ -n ${ROOT} ]] && return
-
- # If they're opting in to the old suid code, then no need to check.
- use suid && return
-
- if awk '$3 == "devpts" && $4 ~ /[, ]gid=5[, ]/ { exit 1 }' /proc/mounts ; then
- eerror "In order to use glibc with USE=-suid, you must make sure that"
- eerror "you have devpts mounted at /dev/pts with the gid=5 option."
- eerror "Openrc should do this for you, so you should check /etc/fstab"
- eerror "and make sure you do not have any invalid settings there."
- die "mount & fix your /dev/pts settings"
- fi
-}
-
# The following Kernel version handling functions are mostly copied from portage
# source. It's better not to use linux-info.eclass here since a) it adds too
# much magic, see bug 326693 for some of the arguments, and b) some of the
@@ -606,9 +585,6 @@ get_kheader_version() {
# pkg_ and src_ phases, so we call this function both in pkg_pretend and in
# src_unpack.
sanity_prechecks() {
- # Make sure devpts is mounted correctly for use w/out setuid pt_chown
- check_devpts
-
# Prevent native builds from downgrading
if [[ ${MERGE_TYPE} != "buildonly" ]] && \
[[ -z ${ROOT} ]] && \