summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-10-24 22:41:26 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-10-24 22:41:39 +0100
commitcbda286a2f7c63bf8075cb999e64c26835530c68 (patch)
tree5a83e08c539966ca30514d90bd42719734987999 /sys-libs/glibc
parenttoolchain-glibc.eclass: drop PIE ewarn (diff)
downloadgentoo-cbda286a2f7c63bf8075cb999e64c26835530c68.tar.gz
gentoo-cbda286a2f7c63bf8075cb999e64c26835530c68.tar.bz2
gentoo-cbda286a2f7c63bf8075cb999e64c26835530c68.zip
sys-libs/glibc: drop PIE ewarn
The ewarn lacks '<gcc-6' guard. Let's drop ewarn completely. Reported-by: Alexander Tsoy Closes: https://bugs.gentoo.org/669410 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.19-r2.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.26-r7.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.27-r6.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.28-r1.ebuild3
-rw-r--r--sys-libs/glibc/glibc-2.28.ebuild5
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild3
6 files changed, 3 insertions, 21 deletions
diff --git a/sys-libs/glibc/glibc-2.19-r2.ebuild b/sys-libs/glibc/glibc-2.19-r2.ebuild
index 3ff1fb95b99b..496ac4d5a31a 100644
--- a/sys-libs/glibc/glibc-2.19-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.19-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -628,9 +628,6 @@ sanity_prechecks() {
ewarn "hypervisor, which is probably not what you want."
fi
- use hardened && ! tc-enables-pie && \
- ewarn "PIE hardening not applied, as your compiler doesn't default to PIE"
-
# Check for sanity of /etc/nsswitch.conf
if [[ -e ${EROOT}/etc/nsswitch.conf ]] ; then
local entry
diff --git a/sys-libs/glibc/glibc-2.26-r7.ebuild b/sys-libs/glibc/glibc-2.26-r7.ebuild
index f912fc41765d..75c16e8a73bb 100644
--- a/sys-libs/glibc/glibc-2.26-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.26-r7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -164,9 +164,6 @@ pkg_pretend() {
ewarn "hypervisor, which is probably not what you want."
fi
- use hardened && ! tc-enables-pie && \
- ewarn "PIE hardening not applied, as your compiler doesn't default to PIE"
-
# Make sure host system is up to date #394453
if has_version '<sys-libs/glibc-2.13' && \
[[ -n $(scanelf -qys__guard -F'#s%F' "${EROOT}"/lib*/l*-*.so) ]]
diff --git a/sys-libs/glibc/glibc-2.27-r6.ebuild b/sys-libs/glibc/glibc-2.27-r6.ebuild
index b176360b42d3..fd3b74726e12 100644
--- a/sys-libs/glibc/glibc-2.27-r6.ebuild
+++ b/sys-libs/glibc/glibc-2.27-r6.ebuild
@@ -638,9 +638,6 @@ sanity_prechecks() {
ewarn "hypervisor, which is probably not what you want."
fi
- use hardened && ! tc-enables-pie && \
- ewarn "PIE hardening not applied, as your compiler doesn't default to PIE"
-
# Check for sanity of /etc/nsswitch.conf
if [[ -e ${EROOT}/etc/nsswitch.conf ]] ; then
local entry
diff --git a/sys-libs/glibc/glibc-2.28-r1.ebuild b/sys-libs/glibc/glibc-2.28-r1.ebuild
index 5d2d8b788b90..8fe52086831d 100644
--- a/sys-libs/glibc/glibc-2.28-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.28-r1.ebuild
@@ -642,9 +642,6 @@ sanity_prechecks() {
ewarn "hypervisor, which is probably not what you want."
fi
- use hardened && ! tc-enables-pie && \
- ewarn "PIE hardening not applied, as your compiler doesn't default to PIE"
-
# Check for sanity of /etc/nsswitch.conf
if [[ -e ${EROOT}/etc/nsswitch.conf ]] ; then
local entry
diff --git a/sys-libs/glibc/glibc-2.28.ebuild b/sys-libs/glibc/glibc-2.28.ebuild
index 8fa03e363049..85d8179bb38c 100644
--- a/sys-libs/glibc/glibc-2.28.ebuild
+++ b/sys-libs/glibc/glibc-2.28.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -642,9 +642,6 @@ sanity_prechecks() {
ewarn "hypervisor, which is probably not what you want."
fi
- use hardened && ! tc-enables-pie && \
- ewarn "PIE hardening not applied, as your compiler doesn't default to PIE"
-
# Check for sanity of /etc/nsswitch.conf
if [[ -e ${EROOT}/etc/nsswitch.conf ]] ; then
local entry
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 8da63740e858..9284afea8665 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -642,9 +642,6 @@ sanity_prechecks() {
ewarn "hypervisor, which is probably not what you want."
fi
- use hardened && ! tc-enables-pie && \
- ewarn "PIE hardening not applied, as your compiler doesn't default to PIE"
-
# Check for sanity of /etc/nsswitch.conf
if [[ -e ${EROOT}/etc/nsswitch.conf ]] ; then
local entry