summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-02-10 23:38:46 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-02-10 23:47:39 +0000
commitd74781e680bee416a48c648df1f8c6000da84e4d (patch)
tree02ed7dbfcf743d54b2a0dffd33796f52be54fca0 /sys-libs/glibc
parenttoolchain-glibc.eclass: disable stack protector on m68k (diff)
downloadgentoo-d74781e680bee416a48c648df1f8c6000da84e4d.tar.gz
gentoo-d74781e680bee416a48c648df1f8c6000da84e4d.tar.bz2
gentoo-d74781e680bee416a48c648df1f8c6000da84e4d.zip
sys-libs/glibc: disable stack protector on m68k
setjmp() clobbers 'a5' register by stack protector prologue. Bug: https://sourceware.org/PR24202 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.27-r6.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.28-r5.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.29.ebuild5
3 files changed, 15 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.27-r6.ebuild b/sys-libs/glibc/glibc-2.27-r6.ebuild
index 668e6795b243..157ab8b051d5 100644
--- a/sys-libs/glibc/glibc-2.27-r6.ebuild
+++ b/sys-libs/glibc/glibc-2.27-r6.ebuild
@@ -809,6 +809,11 @@ glibc_do_configure() {
local myconf=()
case ${CTARGET} in
+ m68k*)
+ # setjmp() is not compatible with stack protection:
+ # https://sourceware.org/PR24202
+ myconf+=( --enable-stack-protector=no )
+ ;;
powerpc-*)
# Currently gcc on powerpc32 generates invalid code for
# __builtin_return_address(0) calls. Normally programs
diff --git a/sys-libs/glibc/glibc-2.28-r5.ebuild b/sys-libs/glibc/glibc-2.28-r5.ebuild
index 827b432313ee..9087d26caafa 100644
--- a/sys-libs/glibc/glibc-2.28-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.28-r5.ebuild
@@ -799,6 +799,11 @@ glibc_do_configure() {
local myconf=()
case ${CTARGET} in
+ m68k*)
+ # setjmp() is not compatible with stack protection:
+ # https://sourceware.org/PR24202
+ myconf+=( --enable-stack-protector=no )
+ ;;
powerpc-*)
# Currently gcc on powerpc32 generates invalid code for
# __builtin_return_address(0) calls. Normally programs
diff --git a/sys-libs/glibc/glibc-2.29.ebuild b/sys-libs/glibc/glibc-2.29.ebuild
index 3089cdbb5f1a..4ac98457b485 100644
--- a/sys-libs/glibc/glibc-2.29.ebuild
+++ b/sys-libs/glibc/glibc-2.29.ebuild
@@ -800,6 +800,11 @@ glibc_do_configure() {
local myconf=()
case ${CTARGET} in
+ m68k*)
+ # setjmp() is not compatible with stack protection:
+ # https://sourceware.org/PR24202
+ myconf+=( --enable-stack-protector=no )
+ ;;
powerpc-*)
# Currently gcc on powerpc32 generates invalid code for
# __builtin_return_address(0) calls. Normally programs