summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-13 21:25:41 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-13 21:25:55 +0100
commitc43f6cb62d492c4f9a7d0e04abdc9d5d007a48be (patch)
tree81d87d0c32e80be993271ad2457b455e92565c29 /sys-libs/gwenhywfar
parentdev-python/kombu: keywording arm64 and spliting out optional deps (diff)
downloadgentoo-c43f6cb62d492c4f9a7d0e04abdc9d5d007a48be.tar.gz
gentoo-c43f6cb62d492c4f9a7d0e04abdc9d5d007a48be.tar.bz2
gentoo-c43f6cb62d492c4f9a7d0e04abdc9d5d007a48be.zip
sys-libs/gwenhywfar: Do not run configuration in src_prepare() (bug #647478 again).
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sys-libs/gwenhywfar')
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-4.19.0.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/sys-libs/gwenhywfar/gwenhywfar-4.19.0.ebuild b/sys-libs/gwenhywfar/gwenhywfar-4.19.0.ebuild
index 4c916a739184..6883b65fbc31 100644
--- a/sys-libs/gwenhywfar/gwenhywfar-4.19.0.ebuild
+++ b/sys-libs/gwenhywfar/gwenhywfar-4.19.0.ebuild
@@ -4,7 +4,7 @@
EAPI=6
MY_P="${P/_beta/beta}"
-inherit autotools qmake-utils
+inherit qmake-utils
DESCRIPTION="A multi-platform helper library for other libraries"
HOMEPAGE="https://www.aquamaniac.de/aqbanking/"
@@ -66,16 +66,14 @@ RESTRICT="test"
S="${WORKDIR}/${MY_P}"
-src_prepare() {
+src_configure() {
disableQtModule() {
local module
for module in ${@}; do
- sed -e "/qtHaveModule(${module})/s/^/#DONT/" -i m4/ax_have_qt.m4 || die
+ sed -e "/qtHaveModule(${module})/s|^|#DONT|" -i configure || die
done
}
- default
-
use designer || disableQtModule designer uitools
use qml || disableQtModule qml qmltest
use sensors || disableQtModule sensors
@@ -83,10 +81,6 @@ src_prepare() {
use test || disableQtModule testlib
use webkit || disableQtModule webkit webkitwidgets
- eautoreconf
-}
-
-src_configure() {
local guis=()
use fox && guis+=( fox16 )
use gtk && guis+=( gtk2 )